summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-14 11:00:56 -0500
committerCarlos Aznarán Laos2023-05-14 11:00:56 -0500
commitd620db1af8085bbaef4d747f96c2d621c315856a (patch)
tree24ef1df02aad95c992d1c145fb8e05bf0c195224
parent17d763f1406953bcf127b1ec73a6e18beb1b0c86 (diff)
downloadaur-d620db1af8085bbaef4d747f96c2d621c315856a.tar.gz
Bump version to 1.0.1
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--CHANGELOG.md107
-rw-r--r--PKGBUILD77
4 files changed, 41 insertions, 154 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddf7b9ebf138..09a682e9f6a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = autodiff
pkgdesc = Automatic differentiation made easier for C++
- pkgver = 0.6.11
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/autodiff/autodiff
- changelog = CHANGELOG.md
arch = any
license = MIT
- makedepends = catch2
makedepends = cmake
makedepends = eigen
makedepends = pybind11
@@ -14,12 +12,12 @@ pkgbase = autodiff
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
- source = autodiff-0.6.11.tar.gz::https://github.com/autodiff/autodiff/archive/v0.6.11.tar.gz
- sha256sums = ac7a52387a10ecb8ba77ce5385ffb23893ff9a623467b4392bd204422a3b5c09
+ source = autodiff-1.0.1.tar.gz::https://github.com/autodiff/autodiff/archive/v1.0.1.tar.gz
+ sha512sums = 8705782023d8e7594aae379b108e459292814200b85146a8935d5f58213fac01e44fa83e2c894dc26133b9fa3cc34995545cbf37d6f5b3800086da3b03d74bef
pkgname = autodiff
pkgname = python-autodiff
- pkgdesc = Automatic differentiation made easier for C++ -- Python bindings
+ pkgdesc = Automatic differentiation made easier for C++ (python bindings)
arch = x86_64
depends = python
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/CHANGELOG.md b/CHANGELOG.md
deleted file mode 100644
index 72a8fcf61769..000000000000
--- a/CHANGELOG.md
+++ /dev/null
@@ -1,107 +0,0 @@
-# Change Log
-
-This file documents important changes to this project, which uses [Semantic Versioning](http://semver.org/).
-
-#[v0.5](https://github.com/autodiff/autodiff/releases/tag/v0.5.0) (June 17, 2019)
-[Full Changelog](https://github.com/autodiff/autodiff/compare/v0.5.0...v0.4.2)
-
-This release introduces a **BREAKING CHANGE**!
-
-From now on, methods `derivative`, `gradient`, and `jacobian` require the
-use of auxiliary functions `wrt` and the newly introduced one `at`.
-
-Examples:
-
-~~~c++
-// f = f(x)
-double dudx = derivative(f, wrt(x), at(x));
-~~~
-
-~~~c++
-// f = f(x, y, z)
-double dudx = derivative(f, wrt(x), at(x, y, z));
-double dudy = derivative(f, wrt(y), at(x, y, z));
-double dudz = derivative(f, wrt(z), at(x, y, z));
-~~~
-
-~~~c++
-// f = f(x), scalar function, where x is an Eigen vector
-VectorXd g = gradient(f, wrt(x), at(x));
-
-// Compuring gradient with respect to only some variables
-VectorXd gpartial = gradient(f, wrt(x.tail(5)), at(x));
-~~~
-
-~~~c++
-// F = F(x), vector function, where x is an Eigen vector
-MatrixXd J = jacobian(f, wrt(x), at(x));
-
-// F = F(x, p), vector function with params, where x and p are Eigen vectors
-MatrixXd Jx = jacobian(f, wrt(x), at(x, p));
-MatrixXd Jp = jacobian(f, wrt(p), at(x, p));
-
-// Compuring Jacobian with respect to only some variables
-MatrixXd Jpartial = jacobian(f, wrt(x.tail(5)), at(x));
-~~~
-
-This release also permits one to retrieve the evaluated value of function during
-a call to the methods `derivative`, `gradient`, and `jacobian`:
-
-~~~c++
-// f = f(x)
-dual u;
-double dudx = derivative(f, wrt(x), at(x), u);
-~~~
-
-~~~c++
-// f = f(x), scalar function, where x is an Eigen vector
-dual u;
-VectorXd g = gradient(f, wrt(x), at(x), u);
-~~~
-
-~~~c++
-// F = F(x), vector function, where x is an Eigen vector
-VectorXdual F;
-MatrixXd J = jacobian(f, wrt(x), at(x), F);
-~~~
-
-#[v0.4.2](https://github.com/autodiff/autodiff/releases/tag/v0.4.2) (Mar 28, 2019)
-[Full Changelog](https://github.com/autodiff/autodiff/compare/v0.4.2...v0.4.1)
-
-This is to force conda-forge to produce a new version (now 0.4.2) since the last
-one (0.4.1) did not work.
-
-#[v0.4.1](https://github.com/autodiff/autodiff/releases/tag/v0.4.1) (Mar 26, 2019)
-[Full Changelog](https://github.com/autodiff/autodiff/compare/v0.4.1...v0.4.0)
-
-This release fixes a bug in the computation of Jacobian matrices when the input
-and output vectors in a vector-valued function have different dimensions (see
-issue [#24](https://github.com/autodiff/autodiff/issues/24)).
-
-#[v0.4.0](https://github.com/autodiff/autodiff/releases/tag/v0.4.0) (Feb 20, 2019)
-[Full Changelog](https://github.com/autodiff/autodiff/compare/v0.4.0...v0.3.0)
-
-This release contains changes that enable autodiff to be successfully compiled
-in Linux, macOS, and Windows. Compilers tested were GCC 7, Clang 9, and Visual
-Studio 2017. Compilers should support C++17.
-
-#[v0.3.0](https://github.com/autodiff/autodiff/releases/tag/v0.3.0) (Feb 5, 2019)
-[Full Changelog](https://github.com/autodiff/autodiff/compare/v0.3.0...v0.2.0)
-
-This release improves the forward mode algorithm to compute derivatives of any
-order. It also introduces a proper website containing a more detailed
-documentation of autodiff library: https://autodiff.github.io
-
-#[v0.2.0](https://github.com/autodiff/autodiff/releases/tag/v0.2.0) (Jul 26, 2018)
-[Full Changelog](https://github.com/autodiff/autodiff/compare/v0.2.0...v0.1.0)
-
-This release permits higher order derivatives to be computed with
-`autodiff::gradx` function and it also enables the use of `autodiff::var` type
-with Eigen vector and matrix types.
-
-#[v0.1.0](https://github.com/autodiff/autodiff/releases/tag/v0.1.0) (Jul 19, 2018)
-[Full Changelog](https://github.com/autodiff/autodiff/compare/v3.6.0...v3.6.1)
-
-This is the first release of autodiff. Please note breaking changes might be
-introduced, but not something that would take you more than a few minutes to
-correct.
diff --git a/PKGBUILD b/PKGBUILD
index 72864e496160..f3973ea3f285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,50 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
pkgbase=autodiff
-pkgname=('autodiff' 'python-autodiff')
-pkgver=0.6.11
+pkgname=(${pkgbase} python-${pkgbase})
+pkgver=1.0.1
pkgrel=1
pkgdesc="Automatic differentiation made easier for C++"
-arch=('any')
-url="https://github.com/autodiff/autodiff"
-license=('MIT')
-makedepends=(
- 'catch2'
- 'cmake'
- 'eigen'
- 'pybind11'
- 'python-build'
- 'python-installer'
- 'python-setuptools'
- 'python-wheel')
-changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('ac7a52387a10ecb8ba77ce5385ffb23893ff9a623467b4392bd204422a3b5c09')
+arch=(any)
+url="https://github.com/${pkgbase}/${pkgbase}"
+license=(MIT)
+makedepends=(cmake eigen pybind11 python-build python-installer python-setuptools python-wheel)
+# checkdepends=(catch2)
+source=(${pkgbase}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('8705782023d8e7594aae379b108e459292814200b85146a8935d5f58213fac01e44fa83e2c894dc26133b9fa3cc34995545cbf37d6f5b3800086da3b03d74bef')
build() {
- cmake \
- -B build \
- -S "$pkgname-$pkgver" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_SHARED_LIBS=ON \
- -DAUTODIFF_BUILD_TESTS=ON \
- -DAUTODIFF_BUILD_PYTHON=ON \
- -DAUTODIFF_BUILD_EXAMPLES=OFF
- cmake --build build
- cd build/python/package
- python -m build --wheel --no-isolation
-}
+ cmake \
+ -S ${pkgbase}-${pkgver} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_CXX_STANDARD=17 \
+ -DAUTODIFF_BUILD_DOCS=OFF \
+ -DAUTODIFF_BUILD_EXAMPLES=OFF \
+ -DAUTODIFF_BUILD_PYTHON=ON \
+ -DAUTODIFF_BUILD_TESTS=OFF
+ cmake --build build
-check() {
- cmake --build build --target tests
+ cd build/python/package
+ python -m build --wheel --skip-dependency-check --no-isolation
}
+# check() {
+# ctest --test-dir build
+# }
+
package_autodiff() {
- DESTDIR="$pkgdir/" cmake --build build --target install
- install -Dm644 "$pkgname-$pkgver/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ DESTDIR="${pkgdir}" cmake --build build --target install
+ install -Dm 644 ${pkgbase}-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
package_python-autodiff() {
- depends=('python')
- arch=('x86_64')
- pkgdesc+=' -- Python bindings'
+ depends=(python)
+ arch=(x86_64)
+ pkgdesc+=" (python bindings)"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" build/python/package/dist/*.whl
- install -Dm644 "$pkgbase-$pkgver/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 ${pkgbase}-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}