summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 09:03:00 -0600
committerMark Wagie2022-04-15 09:03:00 -0600
commit0176c45b3aec9c0017a878ac8f0ea39476905ffc (patch)
treed44abf6d656f4bf75d585545644b19586bddbf30
parent402b9a95a76fde73708fd5b5211a231be5b9e66b (diff)
downloadaur-0176c45b3aec9c0017a878ac8f0ea39476905ffc.tar.gz
standards based build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fccbf32783c0..45047e1a83fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = autokey
pkgver = 0.95.10
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/autokey/autokey
arch = x86_64
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-pyqt5
+ makedepends = python-setuptools
+ makedepends = python-wheel
source = autokey-0.95.10.tar.gz::https://github.com/autokey/autokey/archive/v0.95.10.tar.gz
source = autokey.patch
sha256sums = e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d
diff --git a/PKGBUILD b/PKGBUILD
index 513a3d352ea4..802e5ee98bae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
pkgname=('autokey-common' 'autokey-gtk' 'autokey-qt')
pkgbase=autokey
pkgver=0.95.10
-pkgrel=4
+pkgrel=5
arch=('x86_64')
url="https://github.com/autokey/autokey"
license=('GPL3')
-makedepends=('python-setuptools' 'python-pyqt5')
+makedepends=('python-build' 'python-installer' 'python-pyqt5' 'python-setuptools' 'python-wheel')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/autokey/autokey/archive/v$pkgver.tar.gz"
"$pkgbase.patch")
sha256sums=('e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d'
@@ -23,7 +23,7 @@ prepare() {
build() {
cd "$pkgbase-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
# remove shebang from python libraries
for lib in $(find lib/autokey/ -name "*.py"); do
@@ -41,7 +41,7 @@ package_autokey-common() {
conflicts=("$pkgbase")
cd "$pkgbase-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip build
+ python -m installer --destdir="$pkgdir" dist/*.whl
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
@@ -61,7 +61,7 @@ package_autokey-gtk() {
conflicts=("$pkgbase-qt")
cd "$pkgbase-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip build
+ python -m installer --destdir="$pkgdir" dist/*.whl
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
@@ -82,7 +82,7 @@ package_autokey-qt() {
conflicts=("$pkgbase-gtk")
cd "$pkgbase-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip build
+ python -m installer --destdir="$pkgdir" dist/*.whl
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")