summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-07-15 14:40:20 -0600
committerMark Wagie2022-07-15 14:40:20 -0600
commitfffd21f6be60769d66a887376bcb500545d943b8 (patch)
treef9a1fe590058349a83c30fb983cda70d799701c7
parentde8495a9e0cb063dffbe80a5de25c2296e48682f (diff)
downloadaur-fffd21f6be60769d66a887376bcb500545d943b8.tar.gz
bump libnotify to 0.8
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8f4719164e5..bfbeb1f62150 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autokey
pkgdesc = A desktop automation utility for Linux and X11
pkgver = 0.96.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/autokey/autokey
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 5eb56b9346e9..5fd1156e6a00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('autokey-common' 'autokey-gtk' 'autokey-qt')
pkgbase=autokey
pkgver=0.96.0
-pkgrel=2
+pkgrel=3
pkgdesc="A desktop automation utility for Linux and X11"
arch=('any')
url="https://github.com/autokey/autokey"
@@ -13,6 +13,13 @@ makedepends=('python-build' 'python-installer' 'python-pyqt5' 'python-setuptools
source=("$pkgbase-$pkgver.tar.gz::https://github.com/autokey/autokey/archive/v$pkgver.tar.gz")
sha256sums=('40341fc4cd9703a34264e9191b5938fc7ed5a6f357992d91e492975d89933acd')
+prepare() {
+ cd "$pkgbase-$pkgver"
+
+ # bump Notify to 0.8
+ sed -i "s/'Notify', '0.7'/'Notify', '0.8'/g" lib/autokey/gtkui/notifier.py
+}
+
build() {
cd "$pkgbase-$pkgver"
python -m build --wheel --no-isolation