summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-05-31 21:05:32 +0200
committerLukáš Jirkovský2015-05-31 21:05:32 +0200
commita822d1d135e3c9a91c71e63f3c5d1979c5dbbb04 (patch)
tree6841f3a5a921bf0cce344f0b9f54256bb6f455c0
downloadaur-autopano-sift-c-hg.tar.gz
initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6250e8fd61e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = autopano-sift-c-hg
+ pkgdesc = Identify key feature points within arbitrary images
+ pkgver = 124.1442bb7179d3
+ pkgrel = 1
+ url = http://hugin.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = subversion
+ makedepends = cmake
+ makedepends = mercurial
+ depends = libxml2
+ depends = libpano13
+ provides = autopano-sift-c
+ conflicts = autopano-sift
+ conflicts = autopano-sift-c
+ source = hg+http://hugin.hg.sourceforge.net:8000/hgroot/hugin/autopano-sift-C
+ md5sums = SKIP
+
+pkgname = autopano-sift-c-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c38d0b63d9f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=autopano-sift-c-hg
+pkgver=124.1442bb7179d3
+pkgrel=1
+pkgdesc="Identify key feature points within arbitrary images"
+arch=('i686' 'x86_64')
+url="http://hugin.sourceforge.net/"
+license=('GPL2')
+depends=('libxml2' 'libpano13')
+makedepends=('subversion' 'cmake' 'mercurial')
+provides=('autopano-sift-c')
+conflicts=('autopano-sift' 'autopano-sift-c')
+source=("hg+http://hugin.hg.sourceforge.net:8000/hgroot/hugin/autopano-sift-C")
+md5sums=('SKIP')
+
+pkgver() {
+ cd autopano-sift-C
+ echo $(hg identify -n).$(hg identify -i)
+}
+
+build() {
+ cd "$srcdir/autopano-sift-C"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$srcdir/autopano-sift-C"
+ make DESTDIR="$pkgdir" install
+}