summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam J. Bowman2017-04-15 17:00:40 -0400
committerWilliam J. Bowman2017-04-15 17:14:59 -0400
commitfd1fc3f079e2c7b95778656edc16cdeb03ce7796 (patch)
tree81535ee3bf98f47e3306c51fa9e058bea214beea
parentdc58cb71bec87b06b80a9bbdbd29afcb79f5b547 (diff)
downloadaur-autosubst.tar.gz
NB: Commit will not build with Coq 8.6; Updated to 1.6
I'm pushing this update even though it will not build with the version of Coq available in the repositories. autosubst is research software and is slow to update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a6e4ecb456f..b3ef048e651b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Apr 15 21:14:50 UTC 2017
pkgbase = autosubst
pkgdesc = Automation for de Bruijn syntax and substition in Coq.
- pkgver = 1.0
+ pkgver = 1.6
pkgrel = 1
- url = https://www.ps.uni-saarland.de/autosubst/
+ url = https://github.com/tebbi/autosubst
arch = i686
arch = x86_64
license = GPL
+ makedepends = camlp5-transitional>=6.12
depends = coq<8.5
- source = https://www.ps.uni-saarland.de/autosubst/releases/autosubst_v1.0.tar.gz
- sha256sums = d659898e0e0bafa740c2368a0510a36c77b22a6b9b0386971e49cfc7b8027a1f
- sha512sums = 4a9f2d3db11a14ccca5ff364814bebf1e4f659f79ee5ded4f6d38d12d8c10b904b9b538b61be7094aae40f3e15d2e018095d8959940b4450256d4637f061fe80
+ source = https://github.com/tebbi/autosubst/archive/v1.6.tar.gz
+ sha256sums = bee082e3bea98d4f9a0672f37d54cfd3b754080f1f341eb041eecd3923e7c13c
+ sha512sums = 7632a3c325cf7a166e91491ebec14d74d60f77b039e1e32f437448ad5ce3a7f5e47b7a14fd18f363a64acc33af92b64181b00b5f8f2158fec0defcea2b0d07db
pkgname = autosubst
diff --git a/PKGBUILD b/PKGBUILD
index d731b8bc41a8..9661c2fd68c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: William J. Bowman <aur@williamjbowman.com>
pkgname=autosubst
-pkgver=1.0
+pkgver=1.6
pkgrel=1
pkgdesc="Automation for de Bruijn syntax and substition in Coq."
-url="https://www.ps.uni-saarland.de/autosubst/"
+url="https://github.com/tebbi/autosubst"
arch=('i686' 'x86_64')
license=('GPL')
depends=('coq<8.5')
makedepends=('camlp5-transitional>=6.12')
-source=(https://www.ps.uni-saarland.de/autosubst/releases/${pkgname}_v${pkgver}.tar.gz)
-sha256sums=('d659898e0e0bafa740c2368a0510a36c77b22a6b9b0386971e49cfc7b8027a1f')
-sha512sums=('4a9f2d3db11a14ccca5ff364814bebf1e4f659f79ee5ded4f6d38d12d8c10b904b9b538b61be7094aae40f3e15d2e018095d8959940b4450256d4637f061fe80')
+source=(https://github.com/tebbi/${pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('bee082e3bea98d4f9a0672f37d54cfd3b754080f1f341eb041eecd3923e7c13c')
+sha512sums=('7632a3c325cf7a166e91491ebec14d74d60f77b039e1e32f437448ad5ce3a7f5e47b7a14fd18f363a64acc33af92b64181b00b5f8f2158fec0defcea2b0d07db')
build() {
- cd $srcdir/
+ cd $srcdir/${pkgname}-${pkgver}
make
}
package(){
- cd $srcdir/
+ cd $srcdir/${pkgname}-${pkgver}
make DESTDIR=$pkgdir 'COQLIB:=$(DESTDIR)/$(shell coqtop -where)/' install
}