summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-04-22 18:09:31 -0300
committerDaniel Bermond2024-04-22 18:09:31 -0300
commit2ff3a47e88b0c41a97021fd74307e11f4551e23a (patch)
treec441ebebce200a905d8319ba3b1cacd271abb43b
parent0fb737f806cea68c11fd83e4ace1601c4bba9f2d (diff)
downloadaur-autotrace.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--010-autotrace-fix-swf-output.patch26
-rw-r--r--PKGBUILD61
3 files changed, 71 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a8af1c406e3..54c81df30b73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = autotrace
- pkgdesc = An utility to trace bitmaps: convert bitmaps to vector graphics, with patches from Sacha Chua
- pkgver = 20200219.65.2.g16136eb
+ pkgdesc = A program for converting bitmap to vector graphics
+ pkgver = 0.31.10
pkgrel = 1
- url = https://github.com/autotrace/autotrace.git
- arch = i686
+ url = https://github.com/autotrace/autotrace/
arch = x86_64
- license = GPL
- license = LGPL
+ license = GPL-2.0-or-later
+ license = LGPL-2.1-or-later
+ checkdepends = procps-ng
makedepends = intltool
- makedepends = git
+ depends = glib2
+ depends = imagemagick
depends = libpng
+ depends = ming
depends = pstoedit
- depends = graphicsmagick
- options = !libtool
- source = git+https://github.com/sachac/autotrace.git#commit=16136eb504794f9af389a5f4ac7339d3bf4b9a66
- sha512sums = SKIP
+ source = https://github.com/autotrace/autotrace/archive/0.31.10/autotrace-0.31.10.tar.gz
+ source = 010-autotrace-fix-swf-output.patch
+ sha256sums = 14627f93bb02fe14eeda0163434a7cb9b1f316c0f1727f0bdf6323a831ffe80d
+ sha256sums = c0698678cb37b4a82d732f113ad4829d1b453d9db18001ffbe3044697b4852bc
pkgname = autotrace
-
diff --git a/010-autotrace-fix-swf-output.patch b/010-autotrace-fix-swf-output.patch
new file mode 100644
index 000000000000..e2d31aa113af
--- /dev/null
+++ b/010-autotrace-fix-swf-output.patch
@@ -0,0 +1,26 @@
+http://bugs.gentoo.org/122035
+
+--- a/src/output-swf.c
++++ b/src/output-swf.c
+@@ -24,7 +24,6 @@
+ #include "spline.h"
+ #include "color.h"
+ #include "output-swf.h"
+-#include <ming.h>
+
+ #define FPS 24.0
+ #define IMGID 1
+
+--- a/src/output-swf.h
++++ b/src/output-swf.h
+@@ -23,7 +23,10 @@
+ #define OUTPUTSWF_H
+
+ #include "output.h"
++#include <ming.h>
+
+ int output_swf_writer(FILE * file, gchar * name, int llx, int lly, int urx, int ury, at_output_opts_type * opts, at_spline_list_array_type shape, at_msg_func msg_func, gpointer msg_data, gpointer user_data);
+
++void fileOutputMethod(byte b, void *data);
++
+ #endif /* Not def: OUTPUTSWF_H */
diff --git a/PKGBUILD b/PKGBUILD
index 990021affa9c..b1555661f2f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,43 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-# Contributor: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
-# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
-# Contributor: forest76 <forestt@poczta.onet.pl>
-# Contributor: Tilman Blumenbach <tilman@ax86.net>
-# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=autotrace
-_date=20200219
-_revision=65
-pkgver=20200219.65.2.g16136eb
+pkgver=0.31.10
pkgrel=1
-pkgdesc='An utility to trace bitmaps: convert bitmaps to vector graphics, with patches from Sacha Chua'
-arch=('i686' 'x86_64')
-url='https://github.com/autotrace/autotrace.git'
-license=('GPL' 'LGPL')
-depends=('libpng' 'pstoedit' 'graphicsmagick')
-makedepends=('intltool' 'git')
-options=('!libtool')
-source=("git+https://github.com/sachac/autotrace.git#commit=16136eb504794f9af389a5f4ac7339d3bf4b9a66")
-sha512sums=('SKIP')
+pkgdesc='A program for converting bitmap to vector graphics'
+arch=('x86_64')
+url='https://github.com/autotrace/autotrace/'
+license=('GPL-2.0-or-later' 'LGPL-2.1-or-later')
+depends=('glib2' 'imagemagick' 'libpng' 'ming' 'pstoedit')
+makedepends=('intltool')
+checkdepends=('procps-ng')
+source=("https://github.com/autotrace/autotrace/archive/${pkgver}/autotrace-${pkgver}.tar.gz"
+ '010-autotrace-fix-swf-output.patch')
+sha256sums=('14627f93bb02fe14eeda0163434a7cb9b1f316c0f1727f0bdf6323a831ffe80d'
+ 'c0698678cb37b4a82d732f113ad4829d1b453d9db18001ffbe3044697b4852bc')
-pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's+travis.++' | tr - .
+prepare() {
+ cd "autotrace-${pkgver}"
+ patch -Np1 -i "${srcdir}/010-autotrace-fix-swf-output.patch"
+ ./autogen.sh
}
build() {
- cd "$pkgname"
- autoreconf -ivf
- intltoolize --force
- aclocal
- ./configure --prefix=/usr --with-pstoedit --with-graphicsmagick
- make
+ cd "autotrace-${pkgver}"
+ ./configure \
+ --prefix='/usr' \
+ --disable-static \
+ --with-magick \
+ --with-png \
+ --with-pstoedit
+ make
+ sed -i "s|@MAGICK_LIBS@|$(pkg-config --libs ImageMagick)|" autotrace.pc
+ sed -i "s|@MAGICK_CFLAGS@|$(pkg-config --cflags ImageMagick)|" autotrace.pc
+}
+
+check() {
+ make -C "autotrace-${pkgver}" check
}
package() {
- cd "$pkgname"
- make install DESTDIR="${pkgdir}"
+ make -C "autotrace-${pkgver}" DESTDIR="$pkgdir" install
}