summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-22 22:39:30 +0100
committersL1pKn072023-01-22 22:39:30 +0100
commit965377105ab2a10e73c1dcbddd6a1c7883933dfa (patch)
treef5bd73ea4d7a34902b329d0035aa13d46badd80d
parent8dee89a02b0180eecbe4e8ab33f4ae37703cc49f (diff)
downloadaur-avisynth-plugin-bwdif-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af747c2010aa..229ab5c8ed02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = avisynth-plugin-bwdif-git
pkgdesc = Plugin for Avisynth: bwdif (GIT version)
- pkgver = 1.2.1.3.g3523a88
+ pkgver = 1.2.4.0.g2c06441
pkgrel = 1
url = https://github.com/Asd-g/AviSynth-BWDIF
arch = x86_64
@@ -8,9 +8,11 @@ pkgbase = avisynth-plugin-bwdif-git
license = Apache
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-bwdif
conflicts = avisynth-plugin-bwdif
+ options = debug
source = bwdif::git+https://github.com/Asd-g/AviSynth-BWDIF.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 63cddb7adf84..16e564c391ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,42 @@
_plug=bwdif
pkgname=avisynth-plugin-${_plug}-git
-pkgver=1.2.1.3.g3523a88
+pkgver=1.2.4.0.g2c06441
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/AviSynth-BWDIF'
license=('GPL' 'Apache')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/AviSynth-BWDIF.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p "${_plug}/build"
-}
-
build() {
- cd "${_plug}/build"
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"