summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-22 23:01:12 +0100
committersL1pKn072023-01-22 23:01:12 +0100
commitcd09d380ed9c5df3a4c7888a693aace5415f79a8 (patch)
tree1ed3cd110eef0f8288f63e5dd37b0be165f8de58
parent9454cdaf8846059525cef57407b364449f79ddd1 (diff)
downloadaur-avisynth-plugin-dedot-git.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a38d4e762b6..ffb36fb5d8e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,9 +8,11 @@ pkgbase = avisynth-plugin-dedot-git
license = Apache
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-dedot
conflicts = avisynth-plugin-dedot
+ options = debug
source = dedot::git+https://github.com/Asd-g/AviSynth-DeDot.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index db8a79ca5f39..06aceb6582cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,36 +8,36 @@ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/AviSynth-DeDot'
license=('GPL' 'Apache')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/AviSynth-DeDot.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p "${_plug}/build"
-}
-
build() {
- cd "${_plug}/build"
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"