summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-08 23:57:23 +0200
committersL1pKn072021-10-08 23:57:23 +0200
commitc64e591e3db8f185a2f57965d53262d30ece3585 (patch)
tree2735f4863b473fbb48f4b6ecda99c8473ad82498
downloadaur-avisynth-plugin-lineslumadiff-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97f31338c3a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = avisynth-plugin-lineslumadiff-git
+ pkgdesc = Plugin for Avisynth: lineslumadiff (GIT version)
+ pkgver = 2.0.0.1.gb914fb7
+ pkgrel = 1
+ url = https://github.com/Asd-g/AviSynth-LinesLumaDiff
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-lineslumadiff
+ conflicts = avisynth-plugin-lineslumadiff
+ source = lineslumadiff::git+https://github.com/Asd-g/AviSynth-LinesLumaDiff.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-lineslumadiff-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d19e1e99e6d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=lineslumadiff
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=2.0.0.1.gb914fb7
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Asd-g/AviSynth-LinesLumaDiff'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Asd-g/AviSynth-LinesLumaDiff.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p "${_plug}/build"
+}
+
+build() {
+ cd "${_plug}/build"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+}