summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-22 23:26:48 +0100
committersL1pKn072023-01-22 23:26:48 +0100
commit258ac6bb0a7cfdbd6e7eb5922339a92897477425 (patch)
tree5d4ea96f54461d348f3d1c99d11924844c8d694c
parent06384403af50eb05d7c0dfcccf6b7dac0c9a9bc6 (diff)
downloadaur-avisynth-plugin-mpeg2decplus-git.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bb0b3c22b06..5a77d25648d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = avisynth-plugin-mpeg2decplus-git
pkgdesc = Plugin for Avisynth: mpeg2decplus (GIT version)
- pkgver = 1.2.0.3.gf8b68fe
+ pkgver = 1.3.0.0.g3bbe326
pkgrel = 1
url = https://github.com/Asd-g/MPEG2DecPlus
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-mpeg2decplus
conflicts = avisynth-plugin-mpeg2decplus
+ options = debug
source = mpeg2decplus::git+https://github.com/Asd-g/MPEG2DecPlus.git
sha256sums = SKIP
pkgname = avisynth-plugin-mpeg2decplus-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3464f415672b..afc7d62180f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,42 @@
_plug=mpeg2decplus
pkgname=avisynth-plugin-${_plug}-git
-pkgver=1.2.0.3.gf8b68fe
+pkgver=1.3.0.0.g3bbe326
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/MPEG2DecPlus'
license=('GPL')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/MPEG2DecPlus.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- cmake "../${_plug}/build" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- install -Dm755 build/libmpeg2decplus.so "${pkgdir}/usr/lib/avisynth/libmpeg2decplus.so"
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
}