summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-23 00:17:51 +0100
committersL1pKn072023-01-23 00:17:51 +0100
commit1e7e5cdaf8eb29cb40062e9ee42eb9c0650393e4 (patch)
treefb29bc14587ea722280a0928e1eb08fe9266dd5c
parentd6fef0c4f31340538460cd0d730aa995892da722 (diff)
downloadaur-avisynth-plugin-tivtc-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86af3b088b62..18684ce552ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = avisynth-plugin-tivtc-git
pkgdesc = Plugin for Avisynth: tivtc (GIT version)
- pkgver = v1.0.26.16.g9c47880
+ pkgver = 1.0.27test1.1.g2c48472
pkgrel = 1
url = https://github.com/pinterf/TIVTC
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-tivtc
conflicts = avisynth-plugin-tivtc
+ options = debug
source = tivtc::git+https://github.com/pinterf/TIVTC.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6448b0fdb8c9..961bb3bdd9f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,49 +2,50 @@
_plug=tivtc
pkgname=avisynth-plugin-${_plug}-git
-pkgver=v1.0.26.16.g9c47880
+pkgver=1.0.27test1.1.g2c48472
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/pinterf/TIVTC'
license=('GPL')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/pinterf/TIVTC.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
- mkdir -p build
+ cd "${_plug}"
+ rm -fr src/include/{avs*,avi*}
- rm -fr "${_plug}/src/include/"{avs*,avi*}
+ sed '35i#include <memory>' \
+ -i src/common/info.h
}
build() {
- cd build
-
CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- cmake "../${_plug}/src" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S "${_plug}/src" -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
- cd ..
make -C "${srcdir}/${_plug}/RetrieveRanges"
}
package(){
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
install -Dm755 "${_plug}/RetrieveRanges/RetrieveRanges" "${pkgdir}/usr/bin/RetrieveRanges"
install -Dm644 "${_plug}/RetrieveRanges/RetrieveRanges-ReadMe.txt" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/RetrieveRanges-ReadMe.txt"