summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Nelless2017-07-26 21:26:11 +0100
committerAndrew Nelless2017-07-26 21:26:11 +0100
commit5cbc9a61c740bbda3538dd3854a1f14a55743437 (patch)
tree96e6ebb60935e622718f0b8bfdd0a18213ee262b
parent5cc86b39c2880399f5f50cbbd8cadf7e721eb20a (diff)
downloadaur-5cbc9a61c740bbda3538dd3854a1f14a55743437.tar.gz
Update to v1.8.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--avro-cpp-boost160.patch218
3 files changed, 9 insertions, 232 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf0104afb07..a7abfa7367ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = avro-cpp
pkgdesc = C++ implementation of the Apache Avro data serialization system
- pkgver = 1.8.1
- pkgrel = 2
+ pkgver = 1.8.2
+ pkgrel = 1
url = https://avro.apache.org/
arch = i686
arch = x86_64
@@ -11,12 +11,10 @@ pkgbase = avro-cpp
makedepends = cmake
makedepends = python2
depends = boost-libs
- source = http://www.us.apache.org/dist/avro/avro-1.8.1/cpp/avro-cpp-1.8.1.tar.gz
+ source = http://www.us.apache.org/dist/avro/avro-1.8.2/cpp/avro-cpp-1.8.2.tar.gz
source = avro-cpp-python2.patch
- source = avro-cpp-boost160.patch
- sha256sums = 6559755ac525e908e42a2aa43444576cba91e522fe989088ee7f70c169bcc403
+ sha256sums = 5328b913882ee5339112fa0178756789f164c9c5162e1c83437a20ee162a3aab
sha256sums = 5d54151dd25e717a19109c97e68ce2a07d3b28b9fd3fb3ae1dc5df06b8600fd4
- sha256sums = 3c35ec2d6982b98accad0663d9ce732718c4c775631a7a07b473613deb9e30c9
pkgname = avro-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 32a2f6875ea2..2e22dcbcc045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Nelless <andrew at nelless dot net>
pkgname='avro-cpp'
-pkgver=1.8.1
-pkgrel=2
+pkgver=1.8.2
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="C++ implementation of the Apache Avro data serialization system"
@@ -12,16 +12,13 @@ depends=('boost-libs')
makedepends=('boost' 'cmake' 'python2')
source=("http://www.us.apache.org/dist/avro/avro-$pkgver/cpp/$pkgname-$pkgver.tar.gz"
- $pkgname-python2.patch
- $pkgname-boost160.patch)
-sha256sums=('6559755ac525e908e42a2aa43444576cba91e522fe989088ee7f70c169bcc403'
- '5d54151dd25e717a19109c97e68ce2a07d3b28b9fd3fb3ae1dc5df06b8600fd4'
- '3c35ec2d6982b98accad0663d9ce732718c4c775631a7a07b473613deb9e30c9')
+ $pkgname-python2.patch)
+sha256sums=('5328b913882ee5339112fa0178756789f164c9c5162e1c83437a20ee162a3aab'
+ '5d54151dd25e717a19109c97e68ce2a07d3b28b9fd3fb3ae1dc5df06b8600fd4')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 -i "$srcdir/$pkgname-python2.patch"
- patch -p1 -i "$srcdir/$pkgname-boost160.patch"
}
build() {
diff --git a/avro-cpp-boost160.patch b/avro-cpp-boost160.patch
deleted file mode 100644
index 86d4229187a9..000000000000
--- a/avro-cpp-boost160.patch
+++ /dev/null
@@ -1,218 +0,0 @@
-diff -uNr avro-cpp-1.8.0.orig/test/buffertest.cc avro-cpp-1.8.0/test/buffertest.cc
---- avro-cpp-1.8.0.orig/test/buffertest.cc 2016-02-04 13:28:36.564240294 +0000
-+++ avro-cpp-1.8.0/test/buffertest.cc 2016-02-04 13:29:06.177573701 +0000
-@@ -64,7 +64,7 @@
-
- void TestReserve()
- {
-- BOOST_MESSAGE( "TestReserve");
-+ BOOST_TEST_MESSAGE( "TestReserve");
- {
- OutputBuffer ob;
- BOOST_CHECK_EQUAL(ob.size(), 0U);
-@@ -111,7 +111,7 @@
-
- void TestGrow()
- {
-- BOOST_MESSAGE( "TestGrow");
-+ BOOST_TEST_MESSAGE( "TestGrow");
- {
- OutputBuffer ob;
-
-@@ -151,7 +151,7 @@
-
- void TestDiscard()
- {
-- BOOST_MESSAGE( "TestDiscard");
-+ BOOST_TEST_MESSAGE( "TestDiscard");
- {
- OutputBuffer ob;
- size_t dataSize = kDefaultBlockSize*2 + kDefaultBlockSize/2;
-@@ -257,7 +257,7 @@
-
- void TestConvertToInput()
- {
-- BOOST_MESSAGE( "TestConvertToInput");
-+ BOOST_TEST_MESSAGE( "TestConvertToInput");
- {
- OutputBuffer ob;
- size_t dataSize = kDefaultBlockSize*2 + kDefaultBlockSize/2;
-@@ -277,7 +277,7 @@
-
- void TestExtractToInput()
- {
-- BOOST_MESSAGE( "TestExtractToInput");
-+ BOOST_TEST_MESSAGE( "TestExtractToInput");
- {
- OutputBuffer ob;
- size_t dataSize = kDefaultBlockSize*2 + kDefaultBlockSize/2;
-@@ -376,7 +376,7 @@
-
- void TestAppend()
- {
-- BOOST_MESSAGE( "TestAppend");
-+ BOOST_TEST_MESSAGE( "TestAppend");
- {
- OutputBuffer ob;
- size_t dataSize = kDefaultBlockSize + kDefaultBlockSize/2;
-@@ -405,7 +405,7 @@
-
- void TestBufferStream()
- {
-- BOOST_MESSAGE( "TestBufferStream");
-+ BOOST_TEST_MESSAGE( "TestBufferStream");
-
- {
- // write enough bytes to a buffer, to create at least 3 blocks
-@@ -456,7 +456,7 @@
-
- void TestBufferStreamEof()
- {
-- BOOST_MESSAGE( "TestBufferStreamEof");
-+ BOOST_TEST_MESSAGE( "TestBufferStreamEof");
-
- TestEof<int32_t>();
-
-@@ -469,7 +469,7 @@
-
- void TestSeekAndTell()
- {
-- BOOST_MESSAGE( "TestSeekAndTell");
-+ BOOST_TEST_MESSAGE( "TestSeekAndTell");
-
- {
- std::string junk = makeString(kDefaultBlockSize/2);
-@@ -501,7 +501,7 @@
-
- void TestReadSome()
- {
-- BOOST_MESSAGE( "TestReadSome");
-+ BOOST_TEST_MESSAGE( "TestReadSome");
- {
- std::string junk = makeString(kDefaultBlockSize/2);
-
-@@ -531,7 +531,7 @@
-
- void TestSeek()
- {
-- BOOST_MESSAGE( "TestSeek");
-+ BOOST_TEST_MESSAGE( "TestSeek");
- {
- const std::string str = "SampleMessage";
-
-@@ -592,7 +592,7 @@
-
- void TestIterator()
- {
-- BOOST_MESSAGE( "TestIterator");
-+ BOOST_TEST_MESSAGE( "TestIterator");
- {
- OutputBuffer ob(2 * kMaxBlockSize + 10);
- BOOST_CHECK_EQUAL(ob.numChunks(), 3);
-@@ -674,7 +674,7 @@
- void TestAsioBuffer()
- {
- using boost::asio::ip::tcp;
-- BOOST_MESSAGE( "TestAsioBuffer");
-+ BOOST_TEST_MESSAGE( "TestAsioBuffer");
- {
- boost::barrier b(2);
-
-@@ -746,7 +746,7 @@
-
- void TestSplit()
- {
-- BOOST_MESSAGE( "TestSplit");
-+ BOOST_TEST_MESSAGE( "TestSplit");
- {
- const std::string str = "This message is to be split";
-
-@@ -773,7 +773,7 @@
-
- void TestSplitOnBorder()
- {
-- BOOST_MESSAGE( "TestSplitOnBorder");
-+ BOOST_TEST_MESSAGE( "TestSplitOnBorder");
- {
-
- const std::string part1 = "This message";
-@@ -812,7 +812,7 @@
-
- void TestSplitTwice()
- {
-- BOOST_MESSAGE( "TestSplitTwice");
-+ BOOST_TEST_MESSAGE( "TestSplitTwice");
- {
- const std::string msg1 = makeString(30);
-
-@@ -842,7 +842,7 @@
-
- void TestCopy()
- {
-- BOOST_MESSAGE( "TestCopy");
-+ BOOST_TEST_MESSAGE( "TestCopy");
-
- const std::string msg = makeString(30);
- // Test1, small data, small buffer
-@@ -998,7 +998,7 @@
- // this is reproducing a sequence of steps that caused a crash
- void TestBug()
- {
-- BOOST_MESSAGE( "TestBug");
-+ BOOST_TEST_MESSAGE( "TestBug");
- {
- OutputBuffer rxBuf;
- OutputBuffer buf;
-@@ -1038,7 +1038,7 @@
-
- void TestForeign ()
- {
-- BOOST_MESSAGE( "TestForeign");
-+ BOOST_TEST_MESSAGE( "TestForeign");
- {
- std::string hello = "hello ";
- std::string there = "there ";
-@@ -1065,7 +1065,7 @@
-
- void TestForeignDiscard ()
- {
-- BOOST_MESSAGE( "TestForeign");
-+ BOOST_TEST_MESSAGE( "TestForeign");
- {
- std::string hello = "hello ";
- std::string again = "again ";
-@@ -1104,7 +1104,7 @@
-
- void TestPrinter()
- {
-- BOOST_MESSAGE( "TestPrinter");
-+ BOOST_TEST_MESSAGE( "TestPrinter");
- {
- OutputBuffer ob;
- addDataToBuffer(ob, 128);
-diff -uNr avro-cpp-1.8.0.orig/test/SchemaTests.cc avro-cpp-1.8.0/test/SchemaTests.cc
---- avro-cpp-1.8.0.orig/test/SchemaTests.cc 2016-02-04 13:28:36.564240294 +0000
-+++ avro-cpp-1.8.0/test/SchemaTests.cc 2016-02-04 13:29:06.177573701 +0000
-@@ -138,19 +138,19 @@
-
- static void testBasic(const char* schema)
- {
-- BOOST_CHECKPOINT(schema);
-+ BOOST_TEST_CHECKPOINT(schema);
- compileJsonSchemaFromString(schema);
- }
-
- static void testBasic_fail(const char* schema)
- {
-- BOOST_CHECKPOINT(schema);
-+ BOOST_TEST_CHECKPOINT(schema);
- BOOST_CHECK_THROW(compileJsonSchemaFromString(schema), Exception);
- }
-
- static void testCompile(const char* schema)
- {
-- BOOST_CHECKPOINT(schema);
-+ BOOST_TEST_CHECKPOINT(schema);
- compileJsonSchemaFromString(std::string(schema));
- }
-