summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasaki Waga2019-06-22 09:11:42 +0900
committerMasaki Waga2019-06-22 09:27:01 +0900
commita9c1d6165a4fbf5d32bd637e08d63260b197518c (patch)
tree91fb13a46405a6494964deb676d8ac07f786c9ed
parenta2d49e7d814fd05dcfaf68156b430bead6771677 (diff)
downloadaur-awj-git.tar.gz
fixed
-rw-r--r--.SRCINFO2
-rw-r--r--PATCH43
-rw-r--r--PKGBUILD4
3 files changed, 35 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e485b04dca14..4f2c8573acd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = awj-git
pkgdesc = script that enables interactive selection and execution of aws-cli commands by using peco
pkgver = r4.660fb41
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/daisuke-awaji/awj
arch = any
license = MIT
diff --git a/PATCH b/PATCH
index 1ba13726561a..f06853a79aae 100644
--- a/PATCH
+++ b/PATCH
@@ -1,15 +1,36 @@
---- awj/awj.orig 2019-06-22 09:07:44.727964804 +0900
-+++ awj/awj 2019-06-22 09:07:56.707819483 +0900
-@@ -1,4 +1,3 @@
+--- awj.orig 2019-06-22 09:23:35.661342954 +0900
++++ awj 2019-06-22 09:24:45.857170666 +0900
+@@ -1,17 +1,3 @@
-awj() {
- $(echo "describe_stacks
- describe_stack_url
- describe_change_set_url
-@@ -10,7 +9,6 @@
- describe_s3
- describe_logs
- describe_aws_batch_jobs" | peco)
+- $(echo "describe_stacks
+-describe_stack_url
+-describe_change_set_url
+-describe_ec2
+-describe_elb
+-describe_alb
+-describe_lambda
+-describe_rds
+-describe_s3
+-describe_logs
+-describe_aws_batch_jobs" | peco)
-}
-
+-
describe_stacks() {
STACK_NAME=`aws cloudformation describe-stacks | \
+ jq -r '.Stacks[] | [.StackName, .StackStatus] | @tsv' | \
+@@ -92,3 +78,15 @@
+ echo "$JOB"
+ aws batch describe-job-definitions --job-definition-name $JOB
+ }
++
++$(echo "describe_stacks
++describe_stack_url
++describe_change_set_url
++describe_ec2
++describe_elb
++describe_alb
++describe_lambda
++describe_rds
++describe_s3
++describe_logs
++describe_aws_batch_jobs" | peco)
diff --git a/PKGBUILD b/PKGBUILD
index 19e20dd6ed3b..b44658da5f26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgname=awj
pkgname=${_pkgname}-git
pkgver=r4.660fb41
-pkgrel=2
+pkgrel=3
pkgdesc='script that enables interactive selection and execution of aws-cli commands by using peco'
arch=('any')
url='https://github.com/daisuke-awaji/awj'
@@ -17,7 +17,7 @@ pkgver() {
}
build() {
- patch patch awj/awj ../PATCH
+ patch awj/awj ../PATCH
}
package() {