summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2015-06-29 13:47:19 +0200
committerStefan Tatschner2015-06-29 13:47:19 +0200
commit91b064bd041830368ed444f3975d5e66a8fe4c02 (patch)
tree773654504fc5381e711cdd5d11d3dd14352b55b5
downloadaur-91b064bd041830368ed444f3975d5e66a8fe4c02.tar.gz
Initial upload: awl 0.55-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--awl.install30
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fc10859356d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = awl
+ pkgdesc = Andrew's php Web Libraries
+ pkgver = 0.55
+ pkgrel = 1
+ url = https://gitlab.com/davical-project/awl/
+ install = awl.install
+ arch = any
+ license = GPL2
+ depends = php
+ depends = make
+ source = awl.tar.gz::https://gitlab.com/davical-project/awl/repository/archive.tar.gz?ref=r0.55
+ sha256sums = 69d8f51e8aefdfb6b5a0fc3e5e32f8b8d650c489079c8ebac5a6b65f2ad3ec89
+
+pkgname = awl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f32b29ac8388
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Stefan Tatschner <stefan@sevenbyte.org>
+# Contributor: Andre Wayand <aur-awl@awayand.sleepmail.com>
+
+pkgname=awl
+pkgver=0.55
+pkgrel=1
+pkgdesc="Andrew's php Web Libraries"
+arch=('any')
+url="https://gitlab.com/davical-project/awl/"
+license=('GPL2')
+depends=('php' 'make')
+install="$pkgname.install"
+source=("${pkgname}.tar.gz::https://gitlab.com/davical-project/awl/repository/archive.tar.gz?ref=r${pkgver}")
+sha256sums=('69d8f51e8aefdfb6b5a0fc3e5e32f8b8d650c489079c8ebac5a6b65f2ad3ec89')
+
+package() {
+ cd "$srcdir/$pkgname.git"
+ install -d "$pkgdir/usr/share/awl"
+ cp -a . $pkgdir/usr/share/awl
+}
+
diff --git a/awl.install b/awl.install
new file mode 100644
index 000000000000..2dd9efb82a97
--- /dev/null
+++ b/awl.install
@@ -0,0 +1,30 @@
+post_install() {
+ echo ""
+ echo "===================================================="
+ echo ""
+ echo "This package includes a bunch of web libraries, mostly"
+ echo "written by Andrew McMillan, and mostly used by PHP things"
+ echo "that he wrote."
+ echo ""
+ echo "They are supposed to be fairly lightweight, and they are"
+ echo "intended to simplify things rather than complexify them."
+ echo ""
+ echo "To use them, you will need to add the path into your PHP"
+ echo "application. The recommended way is to do this inside"
+ echo "the Apache virtual host, like so:"
+ echo ""
+ echo " php_value include_path ../inc:/usr/share/awl/inc"
+ echo ""
+ echo "Which would include your applications inc directory"
+ echo "first, allowing it to override any AWL functionality"
+ echo "it wanted to."
+ echo ""
+ echo "Alternatively, add /usr/share/awl/inc under include_path"
+ echo "in your php.ini file for global availability"
+ echo "===================================================="
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}