summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2017-09-08 17:39:01 +0200
committerCarsten Feuls2017-09-08 17:39:01 +0200
commit559ff419f46b95a947967975ae26514944eb63da (patch)
treef645627b1ee4fd01f294c349b6d1ed610070ac7a
downloadaur-awx-git.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..310d9067fcd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Sep 8 15:38:48 UTC 2017
+pkgbase = awx-git
+ pkgdesc = AWX provides a web-based user interface, REST API, and task engine built on top of Ansible.
+ pkgver = r14744.1.0.0_294_g0da416b1413b
+ pkgrel = 1
+ url = https://github.com/ansible/awx
+ arch = any
+ license = Apache-2.0
+ depends = python2
+ depends = gettext
+ options = !emptydirs
+ source = git+https://github.com/ansible/awx.git
+ sha256sums = SKIP
+
+pkgname = awx-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acd401881710
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+pkgname=awx-git
+pkgver=r14744.1.0.0_294_g0da416b1413b
+pkgrel=1
+pkgdesc="AWX provides a web-based user interface, REST API, and task engine built on top of Ansible."
+arch=('any')
+url="https://github.com/ansible/awx"
+license=('Apache-2.0')
+depends=('python2' 'gettext')
+options=(!emptydirs)
+source=("git+https://github.com/ansible/awx.git")
+
+pkgver() {
+ cd awx
+ echo "r$(git rev-list --count HEAD).$(git describe --always | sed 's/-/_/g')"
+}
+
+build() {
+ cd "${srcdir}/awx"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/awx"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+sha256sums=('SKIP')