summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNandor Magyar2024-05-08 14:29:16 +0200
committerNandor Magyar2024-05-08 14:29:16 +0200
commit4ecd215810e77d3af40c6c1a66c8c9ce57003dce (patch)
tree82a62efa9182f9c799e6a5377ddf8d61883e20bd
parent492b6cc7ce9ffbc9c2664292611e9f6e52a1853a (diff)
downloadaur-azcopy-bin.tar.gz
fix versioning, add correct LICENSE
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c4f180aabcc..0a6ca687f625 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = azcopy-bin
pkgdesc = A command-line utility that you can use to copy data to and from containers and file shares in Azure Storage accounts.
pkgver = 10.24.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Azure/azure-storage-azcopy
arch = x86_64
license = MIT
- provides = azcopy
+ provides = azcopy=10.24.0
conflicts = azcopy
- source = https://aka.ms/downloadazcopy-v10-linux
- sha256sums = 4932dd2bd3b97631938ab2bf9f73b73a7a2a9b62f0daa9341006fc64c4833883
+ source = LICENSE-10.24.0::https://raw.githubusercontent.com/Azure/azure-storage-azcopy/v10.24.0/LICENSE
+ sha256sums = e9ca6f8518c969a4d3bb98030581771975a90730a27d294123855c90a31eddcc
+ source_x86_64 = https://aka.ms/downloadazcopy-v10-linux
+ sha256sums_x86_64 = 4932dd2bd3b97631938ab2bf9f73b73a7a2a9b62f0daa9341006fc64c4833883
pkgname = azcopy-bin
diff --git a/PKGBUILD b/PKGBUILD
index ed9c4dbe82fd..14e74fe1e2c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,19 @@
_name=azcopy
pkgname=azcopy-bin
pkgver=10.24.0
-pkgrel=3
+pkgrel=4
pkgdesc="A command-line utility that you can use to copy data to and from containers and file shares in Azure Storage accounts."
arch=('x86_64')
url="https://github.com/Azure/azure-storage-azcopy"
license=('MIT')
-provides=("${_name}")
+provides=("${_name}=${pkgver}")
conflicts=("${_name}")
-source=("https://aka.ms/downloadazcopy-v10-linux")
-sha256sums=('4932dd2bd3b97631938ab2bf9f73b73a7a2a9b62f0daa9341006fc64c4833883')
+source=("LICENSE-${pkgver}::https://raw.githubusercontent.com/Azure/azure-storage-azcopy/v${pkgver}/LICENSE")
+source_x86_64=("${_name}-bin-${pkgver}-x86_64::https://aka.ms/downloadazcopy-v10-linux")
+sha256sums=('e9ca6f8518c969a4d3bb98030581771975a90730a27d294123855c90a31eddcc')
+sha256sums_x86_64=('4932dd2bd3b97631938ab2bf9f73b73a7a2a9b62f0daa9341006fc64c4833883')
package() {
- install -Dm755 "${_name}_linux_amd64_${pkgver}/${_name}" "$pkgdir"/usr/bin/"${_name}"
- install -Dm644 "${_name}_linux_amd64_${pkgver}/${_name}" -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm755 "${srcdir}/${_name}_linux_amd64_${pkgver}/${_name}" "${pkgdir}/usr/bin/${_name}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}