summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Düll2015-07-04 14:01:52 +0200
committerMichael Düll2015-07-04 14:01:52 +0200
commit7f59e3aceea023b3bd3d6030f47f1dadeb324f78 (patch)
tree02e86310b762eefb535c8c6c1c965d6f0aa0a037
downloadaur-b2sum.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a746779363d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = b2sum
+ pkgdesc = Computes the BLAKE2 (BLAKE2b or -s, -bp, -sp) cryptographic hash of a given file. STDIN not supported (yet?).
+ pkgver = 20150531
+ pkgrel = 1
+ url = https://blake2.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = https://blake2.net/blake2_code_20150531.zip
+ sha384sums = 14dad3b898c69ee0891bf72a970ca331dd121940a16780a5ec72e789d4bcf239299e36091dfb357c5aba10bf57c3cbd6
+
+pkgname = b2sum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72eed03d6f7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michael Düll <michael.duell@rub.de>
+# Contributor: Dalton Miller
+pkgname=b2sum
+pkgver=20150531
+pkgrel=1
+pkgdesc="Computes the BLAKE2 (BLAKE2b or -s, -bp, -sp) cryptographic hash of a given file. STDIN not supported (yet?)."
+_prefix="blake2_code_"
+arch=('i686' 'x86_64')
+url="https://blake2.net/"
+license=('custom')
+source=("https://blake2.net/${_prefix}${pkgver}.zip")
+
+prepare() {
+ cd "${srcdir}/${_prefix}${pkgver}/b2sum"
+ sed -i "s# -fopenmp##" makefile
+ make clean
+}
+
+build() {
+ cd "${srcdir}/${_prefix}${pkgver}/b2sum"
+ make all
+}
+
+package() {
+ cd "${srcdir}/${_prefix}${pkgver}/b2sum"
+ install -d "${pkgdir}/usr/bin"
+ install -Dm 755 b2sum "${pkgdir}/usr/bin"
+}
+sha384sums=('14dad3b898c69ee0891bf72a970ca331dd121940a16780a5ec72e789d4bcf239299e36091dfb357c5aba10bf57c3cbd6')