summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2021-04-04 09:12:54 +0300
committerAnton Leontiev2021-04-04 09:13:40 +0300
commit0c26136043081f560022b2b8f621723b39152f8d (patch)
treeea6218f448bee9bb6b12c113c366917c85193095
downloadaur-b63-git.tar.gz
b63-git: New package
B63 is a light-weight micro-benchmarking header-only library for C.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71649bc96c9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = b63-git
+ pkgdesc = Light-weight micro-benchmarking tool for C
+ pkgver = r33.26ce28b
+ pkgrel = 1
+ url = https://github.com/okuvshynov/b63
+ arch = any
+ license = Apache
+ makedepends = git
+ provides = b63
+ conflicts = b63
+ source = b63::git+https://github.com/okuvshynov/b63.git
+ md5sums = SKIP
+
+pkgname = b63-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72fa9e8e7da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Anton Leontiev <scileont /at/ gmail.com>
+pkgname=b63-git
+pkgver=r33.26ce28b
+pkgrel=1
+pkgdesc='Light-weight micro-benchmarking tool for C'
+arch=('any')
+url='https://github.com/okuvshynov/b63'
+license=('Apache')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/okuvshynov/b63.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -dm755 "$pkgdir/usr/include"
+ cp -dr --no-preserve=ownership src "$pkgdir/usr/include/b63"
+}