summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2017-06-08 15:57:59 +0200
committerJosip Ponjavic2017-06-08 15:57:59 +0200
commit0baf290ac9c9fdf9b8410b6c60b2a8649322fd1f (patch)
tree93038dd116cccb4c9545d37d35fd1485669443fb
parentfeaf4deb051c2d38ff4d74b407f5418d442f30df (diff)
downloadaur-0baf290ac9c9fdf9b8410b6c60b2a8649322fd1f.tar.gz
bump, update pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a967a11644b9..e51a5e7578e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = babe-git
- pkgdesc = Tiny Qt Babe Music Player
- pkgver = r41.g60913c8
+ pkgdesc = Tiny Qt Music Player to keep your favorite songs at hand
+ pkgver = 0.0.Alpha.r126.g62a84b2
pkgrel = 1
url = https://babe.kde.org/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 943141b17410..05329417d076 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=babe-git
-pkgver=r41.g60913c8
+pkgver=0.0.Alpha.r126.g62a84b2
pkgrel=1
-pkgdesc='Tiny Qt Babe Music Player'
+pkgdesc='Tiny Qt Music Player to keep your favorite songs at hand'
arch=('i686' 'x86_64')
url="https://babe.kde.org/"
license=('GPL3')
@@ -18,7 +18,8 @@ sha256sums=('SKIP')
pkgver() {
cd babe
- printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ version=$(grep "Verion: " about.cpp | awk '{print $5 "." $6}' | awk -F'\' '{print $1}')
+ printf '%s.r%s.g%s' "$version" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {