summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-04-17 07:43:31 +0200
committeraksr2016-04-17 07:43:31 +0200
commit99b26676a0738bba2fe6779436cb565bece133b1 (patch)
tree01de36f9dd94a31feb7259a7f0d7e485328b6c54
downloadaur-backupfs-git.tar.gz
Start.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
-rw-r--r--backupfs.install17
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..094510a62222
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Apr 17 05:43:30 UTC 2016
+pkgbase = backupfs-git
+ pkgdesc = A network extended command level clone of the Plan 9 dump file system.
+ pkgver = r11.6365b8d
+ pkgrel = 1
+ url = https://github.com/hariguchi/backupfs
+ install = backupfs.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ conflicts = backupfs
+ source = backupfs-git::git+https://github.com/hariguchi/backupfs.git
+ md5sums = SKIP
+
+pkgname = backupfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c473a2603170
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=backupfs-git
+pkgver=r11.6365b8d
+pkgrel=1
+epoch=
+pkgdesc="A network extended command level clone of the Plan 9 dump file system."
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/backupfs/"
+url="https://github.com/hariguchi/backupfs"
+license=('BSD')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('backupfs')
+replaces=()
+backup=()
+options=()
+changelog=
+install=${pkgname%-*}.install
+source=("$pkgname::git+https://github.com/hariguchi/backupfs.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ sed -i '173,183'd Makefile
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/{bin,/share/man}
+ make PREFIX="$pkgdir/usr" TGTGRP="root" MANDIR="$pkgdir/usr/share/man" install
+ install -Dm644 cron.daily-backup.sh $pkgdir/usr/share/doc/$pkgname/cron.daily-backup.sh
+ install -Dm644 README $pkgdir/usr/share/doc/$pkgname/README
+ install -Dm644 BUGS $pkgdir/usr/share/doc/$pkgname/BUGS
+}
+
diff --git a/backupfs.install b/backupfs.install
new file mode 100644
index 000000000000..4de047b81b00
--- /dev/null
+++ b/backupfs.install
@@ -0,0 +1,17 @@
+post_install() {
+ egrep backupfs /etc/group >/dev/null || groupadd -g 65530 backupfs
+ egrep backupfs /etc/passwd >/dev/null || \
+ useradd -u 65530 -g 65530 -d /home/backupfs -s /usr/bin/backupfs-shell -c 'backupfs, daily backup system' backupfs
+ chown backupfs:backupfs /usr/bin/{backupfs,backupfs{-remote,-chksrc,-exctar,-mkdir,-mklink,-shell,-hist}}
+ chown backupfs:backupfs /usr/bin/newfiles
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ sed -i '/backupfs:x:65530:/d' etc/group
+ sed -i '/backupfs:x:65530:/d' etc/passwd
+}
+