summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-06-28 18:49:40 +0200
committerMartchus2023-06-28 18:49:40 +0200
commit318c087df8fb779ef97873bf708ea4d134b374f5 (patch)
treef9cbd523601cd947fa5eef6a2ca41229a2f08997
parentb2c1a52bb1db2a655007d25d590f8727977b66cf (diff)
downloadaur-318c087df8fb779ef97873bf708ea4d134b374f5.tar.gz
Fix addressbook sync after php update
-rw-r--r--.SRCINFO4
-rw-r--r--906bbb8969c8712e108bd6a721114cc199bb684c.patch39
-rw-r--r--PKGBUILD13
3 files changed, 52 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6141fbcaa06..a1841d67442c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = baikal
pkgdesc = Lightweight CalDAV+CardDAV server
pkgver = 0.9.3
- pkgrel = 1
+ pkgrel = 2
url = http://sabre.io/baikal/
install = baikal.install
arch = any
@@ -12,8 +12,10 @@ pkgbase = baikal
optdepends = php-sqlite: To use the sqlite backend
options = !strip
source = https://github.com/fruux/Baikal/releases/download/0.9.3/baikal-0.9.3.zip
+ source = 906bbb8969c8712e108bd6a721114cc199bb684c.patch
source = baikal.install
sha512sums = bdcd3848ba7c99f94a1f20c9fee48f24bb9e004a325f482d6b5324eff1f0aa2fddd284ff5f9ae6dd0b67455852aa82e434174358c58d76b6009945bc3395768c
+ sha512sums = bad0002fe73330b0991dc448dc59fcf4257c7c1bfacaa0042ea552ea0fe316e6bf157afed75df7361e707c9bfa258135d8b01dad273adceac0127cb44d4f84d0
sha512sums = 4e28980100ce9fc820a6c40a9cd528a90d62997ac18fb4ea353d8eaba58b320f9c653ba9b066036ff598f1d5a0aafb49ba444f9187c0d3616cbe6fa45222ca3f
pkgname = baikal
diff --git a/906bbb8969c8712e108bd6a721114cc199bb684c.patch b/906bbb8969c8712e108bd6a721114cc199bb684c.patch
new file mode 100644
index 000000000000..827c7f4fa243
--- /dev/null
+++ b/906bbb8969c8712e108bd6a721114cc199bb684c.patch
@@ -0,0 +1,39 @@
+From 906bbb8969c8712e108bd6a721114cc199bb684c Mon Sep 17 00:00:00 2001
+From: Phil Davis <phil@jankaritech.com>
+Date: Mon, 30 Jan 2023 12:39:44 +0545
+Subject: [PATCH] declare addressDataProperties to avoid PHP 8.2 deprecation
+ notice
+
+---
+ lib/CardDAV/Xml/Request/AddressBookMultiGetReport.php | 9 ++++++++-
+ ...ultiGetTest.php => AddressBookMultiGetReportTest.php} | 6 +++---
+ 2 files changed, 11 insertions(+), 4 deletions(-)
+ rename tests/Sabre/CardDAV/Xml/Request/{AddressBookMultiGetTest.php => AddressBookMultiGetReportTest.php} (93%)
+
+diff --git a/lib/CardDAV/Xml/Request/AddressBookMultiGetReport.php b/lib/CardDAV/Xml/Request/AddressBookMultiGetReport.php
+index c11d2dd736..491f969088 100644
+--- a/lib/CardDAV/Xml/Request/AddressBookMultiGetReport.php
++++ b/lib/CardDAV/Xml/Request/AddressBookMultiGetReport.php
+@@ -38,7 +38,7 @@ class AddressBookMultiGetReport implements XmlDeserializable
+ public $hrefs;
+
+ /**
+- * The mimetype of the content that should be returend. Usually
++ * The mimetype of the content that should be returned. Usually
+ * text/vcard.
+ *
+ * @var string
+@@ -53,6 +53,13 @@ class AddressBookMultiGetReport implements XmlDeserializable
+ */
+ public $version = null;
+
++ /**
++ * An array with requested vcard properties.
++ *
++ * @var array
++ */
++ public $addressDataProperties;
++
+ /**
+ * The deserialize method is called during xml parsing.
+ *
diff --git a/PKGBUILD b/PKGBUILD
index 224f2e1a1385..7b011c6bf569 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=baikal
pkgver=0.9.3
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight CalDAV+CardDAV server'
url='http://sabre.io/baikal/'
arch=('any')
@@ -11,18 +11,25 @@ license=('GPL')
depends=('php')
optdepends=('sqlite: Database' 'mariadb: Alternate database' 'php-sqlite: To use the sqlite backend')
source=("https://github.com/fruux/Baikal/releases/download/$pkgver/baikal-$pkgver.zip"
+ "906bbb8969c8712e108bd6a721114cc199bb684c.patch"
'baikal.install')
sha512sums=('bdcd3848ba7c99f94a1f20c9fee48f24bb9e004a325f482d6b5324eff1f0aa2fddd284ff5f9ae6dd0b67455852aa82e434174358c58d76b6009945bc3395768c'
+ 'bad0002fe73330b0991dc448dc59fcf4257c7c1bfacaa0042ea552ea0fe316e6bf157afed75df7361e707c9bfa258135d8b01dad273adceac0127cb44d4f84d0'
'4e28980100ce9fc820a6c40a9cd528a90d62997ac18fb4ea353d8eaba58b320f9c653ba9b066036ff598f1d5a0aafb49ba444f9187c0d3616cbe6fa45222ca3f')
options=('!strip')
install=baikal.install
+prepare() {
+ cd "${srcdir}/baikal/vendor/sabre/dav"
+ patch -p1 -i ../../../../906bbb8969c8712e108bd6a721114cc199bb684c.patch
+}
+
package() {
cd "${srcdir}/baikal"
install -dm 755 "$pkgdir"/usr/share/{webapps,doc}"/$pkgname"
- install -dm 700 -o http -g http "$pkgdir/var/lib/$pkgname"
- install -dm 700 -o http -g http "$pkgdir/var/lib/$pkgname/config"
+ install -dm 700 "$pkgdir/var/lib/$pkgname"
+ install -dm 700 "$pkgdir/var/lib/$pkgname/config"
cp -R Core html vendor "$pkgdir/usr/share/webapps/$pkgname"
install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname"
ln -s "/var/lib/$pkgname" "$pkgdir/usr/share/webapps/$pkgname/Specific"