summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2019-08-02 10:33:35 +0100
committerMatthew McGinn2019-08-02 11:01:18 +0100
commit57c9100a75f6add8904634418667ba033affd6f3 (patch)
tree0457f3a24371453bf2b02d3bf8ba2ab3696b1596
parent07ae1ab1483036675d066a61663ccd5260fa865b (diff)
downloadaur-57c9100a75f6add8904634418667ba033affd6f3.tar.gz
update version to v11.7.4
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3745ffb5f973..136502ff41ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = balena-cli
pkgdesc = balena.io command line interface
- pkgver = 11.7.3
- pkgrel = 2
+ pkgver = 11.7.4
+ pkgrel = 1
url = https://balena.io/
arch = i686
arch = x86_64
license = APACHE
makedepends = npm
makedepends = python2
+ makedepends = jq
depends = nodejs>=6.0.0
optdepends = python: balena-preload
replaces = resin-cli
- noextract = balena-cli-11.7.3.tgz
+ noextract = balena-cli-11.7.4.tgz
options = !strip
- source = http://registry.npmjs.org/balena-cli/-/balena-cli-11.7.3.tgz
- sha256sums = acc3ba4e22cb4561e867a6a224e3ddfdf9feb2b63b34b0a25079afdb810c97af
+ source = http://registry.npmjs.org/balena-cli/-/balena-cli-11.7.4.tgz
+ sha256sums = c60b298d110ff8d440d98415f5bb7d5e1d66fc119f99fff1a3131ffc5ed94a74
optdepends_x86_64 = lib32-glibc: emulated builds
pkgname = balena-cli
diff --git a/PKGBUILD b/PKGBUILD
index ffcd3153fe93..832b3f762794 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,31 @@
pkgname=balena-cli
pkgdesc='balena.io command line interface'
-pkgver=11.7.3
-pkgrel=2
+pkgver=11.7.4
+pkgrel=1
arch=('i686' 'x86_64')
url='https://balena.io/'
_github_url="https://github.com/balena-io/balena-cli"
license=('APACHE')
depends=('nodejs>=6.0.0')
-makedepends=('npm' 'python2')
+makedepends=('npm' 'python2' 'jq')
source=(http://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz)
noextract=(${pkgname}-${pkgver}.tgz)
options=(!strip)
optdepends=('python: balena-preload')
optdepends_x86_64=('lib32-glibc: emulated builds')
replaces=('resin-cli')
-sha256sums=('acc3ba4e22cb4561e867a6a224e3ddfdf9feb2b63b34b0a25079afdb810c97af')
+sha256sums=('c60b298d110ff8d440d98415f5bb7d5e1d66fc119f99fff1a3131ffc5ed94a74')
package() {
npm install --global --production --no-shrinkwrap --user root --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
+
+ find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+ local tmppackage="$(mktemp)"
+ local pkgjson="${pkgdir}/usr/lib/node_modules/${pkgname}/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "${pkgjson}" > "${tmppackage}"
+ mv "${tmppackage}" "${pkgjson}"
+ chmod 644 "${pkgjson}"
}