summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2024-03-21 17:47:21 +0100
committerMarcell Meszaros2024-03-21 17:52:33 +0100
commit23b0e81d89d5bd0a04e6a50d499fde2ff823c4a2 (patch)
treeea97cbc6ce9c935794cd95e8193c07096cec57a4
parentc6b7c05e5eab032eb72c9224e09f7a77458d212b (diff)
downloadaur-baloo-widgets-git.tar.gz
24.01.90.r15.g87158a4-1: update license, use '-git' deps
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD46
2 files changed, 38 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 801e70a3f5eb..7c091e009ce8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,28 @@
pkgbase = baloo-widgets-git
pkgdesc = Widgets for Baloo (Git)
- pkgver = 24.01.75.r5.gd46693c
- pkgrel = 2
+ pkgver = 24.01.90.r15.g87158a4
+ pkgrel = 1
url = https://invent.kde.org/libraries/baloo-widgets
arch = i686
arch = x86_64
- license = LGPL
+ license = LGPL-2.1-only OR LGPL-3.0-only OR LicenseRef-KDE-Accepted-LGPL
makedepends = extra-cmake-modules-git
makedepends = git
- makedepends = kdoctools
+ makedepends = kdoctools-git
depends = gcc-libs
depends = glibc
- depends = baloo
- depends = kconfig
- depends = kcoreaddons
- depends = kfilemetadata
- depends = ki18n
- depends = kio
- depends = kservice
- depends = kwidgetsaddons
+ depends = baloo-git
+ depends = kconfig-git
+ depends = kcoreaddons-git
+ depends = kfilemetadata-git
+ depends = ki18n-git
+ depends = kio-git
+ depends = kservice-git
+ depends = kwidgetsaddons-git
depends = qt6-base
- provides = baloo-widgets=24.01.75
+ provides = baloo-widgets=24.01.90
conflicts = baloo-widgets
- conflicts = kf5-transition-dummy
- source = git+https://invent.kde.org/libraries/baloo-widgets.git
+ source = baloo-widgets::git+https://invent.kde.org/libraries/baloo-widgets.git
b2sums = SKIP
pkgname = baloo-widgets-git
diff --git a/PKGBUILD b/PKGBUILD
index d6c3d5b527a5..f04cb22d430f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,47 @@
+# Maintainer:
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: katt <magunasu.b97@gmail.com>
# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
-_pkgname='baloo-widgets'
-pkgname="${_pkgname}-git"
-pkgver=24.01.75.r5.gd46693c
-pkgrel=2
+_distname='baloo-widgets'
+pkgname="${_distname}-git"
+pkgver=24.01.90.r15.g87158a4
+pkgrel=1
pkgdesc='Widgets for Baloo (Git)'
arch=('i686' 'x86_64')
-url="https://invent.kde.org/libraries/${_pkgname}"
-license=('LGPL')
+url="https://invent.kde.org/libraries/${_distname}"
+license=('LGPL-2.1-only OR LGPL-3.0-only OR LicenseRef-KDE-Accepted-LGPL')
depends=(
'gcc-libs'
'glibc'
- 'baloo'
- 'kconfig'
- 'kcoreaddons'
- 'kfilemetadata'
- 'ki18n'
- 'kio'
- 'kservice'
- 'kwidgetsaddons'
+ 'baloo-git'
+ 'kconfig-git'
+ 'kcoreaddons-git'
+ 'kfilemetadata-git'
+ 'ki18n-git'
+ 'kio-git'
+ 'kservice-git'
+ 'kwidgetsaddons-git'
'qt6-base'
)
makedepends=(
'extra-cmake-modules-git'
'git'
- 'kdoctools'
+ 'kdoctools-git'
)
-provides=("${_pkgname}=${pkgver%.r*}")
-conflicts=("${_pkgname}"
- 'kf5-transition-dummy' # needs to avoid pulling in this fake package
-)
-source=("${_pkgname}::git+${url}.git")
+provides=("${_distname}=${pkgver%.r*}")
+conflicts=("${_distname}")
+source=("${_distname}::git+${url}.git")
b2sums=('SKIP')
pkgver() {
- git -C "${_pkgname}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "${_distname}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir"
- cmake -B build -S "${_pkgname}" \
+ cmake -B build -S "${_distname}" \
-DBUILD_TESTING=OFF \
-DBUILD_WITH_QT6=ON \
-DQT_MAJOR_VERSION=6
@@ -51,4 +50,7 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --install build
+
+ cd "${_distname}/LICENSES"
+ install -Dm644 LicenseRef-KDE-Accepted-LGPL.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}