summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2022-10-04 22:27:08 +0200
committerOleksandr Natalenko2022-10-04 22:27:08 +0200
commit202bf7e5606df3460715a9dec2bdee9b6ff3fc61 (patch)
treedc61ae6bbc1a9ca222ed6efe5f2770c8515ff7bd
parentaa9344cbd9b124077f3fae58c5b6f26314530207 (diff)
downloadaur-bandwidthd.tar.gz
update to v2.0.13
Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b7bd2c0daff..b749c8e2e168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bandwidthd
pkgdesc = Daemon for graphing traffic of subnet machines
- pkgver = 2.0.11
- pkgrel = 2
+ pkgver = 2.0.13
+ pkgrel = 1
epoch = 1
url = https://codeberg.org/post-factum/bandwidthd
arch = x86_64
@@ -11,10 +11,14 @@ pkgbase = bandwidthd
depends = libpcap
depends = libpng
depends = gd
- depends = nginx
backup = etc/bandwidthd/bandwidthd.conf
- backup = etc/bandwidthd/bandwidthd-webui.conf
- source = bandwidthd-2.0.11.tar.gz::https://codeberg.org/post-factum/bandwidthd/archive/v2.0.11.tar.gz
- sha256sums = e9a42e675012ab3c95e9d968a67c1c3fa53d41b1cc81205a7f3625d5a85c94ea
+ backup = etc/bandwidthd/Caddyfile
+ source = https://codeberg.org/post-factum/bandwidthd/archive/v2.0.13.tar.gz
+ sha256sums = e4761abe5e06a7ff1ecde7643d54c45390f33129c6de074fbd4df74e3c26f740
pkgname = bandwidthd
+ depends = sqlite
+ depends = libpcap
+ depends = libpng
+ depends = gd
+ depends = caddy
diff --git a/PKGBUILD b/PKGBUILD
index ceec1c8c4f4a..9b91a1a65d23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
pkgname=bandwidthd
_repouser=post-factum
_reponame=bandwidthd
-pkgver=2.0.11
-pkgrel=2
+pkgver=2.0.13
+pkgrel=1
epoch=1
pkgdesc="Daemon for graphing traffic of subnet machines"
arch=(x86_64)
url="https://codeberg.org/post-factum/bandwidthd"
license=(GPL)
-depends=(sqlite libpcap libpng gd nginx)
+depends=(sqlite libpcap libpng gd)
makedepends=(meson)
-source=(${pkgname}-${pkgver}.tar.gz::https://codeberg.org/${_repouser}/${_reponame}/archive/v${pkgver}.tar.gz)
+source=(https://codeberg.org/${_repouser}/${_reponame}/archive/v${pkgver}.tar.gz)
-sha256sums=('e9a42e675012ab3c95e9d968a67c1c3fa53d41b1cc81205a7f3625d5a85c94ea')
+sha256sums=('e4761abe5e06a7ff1ecde7643d54c45390f33129c6de074fbd4df74e3c26f740')
backup=('etc/bandwidthd/bandwidthd.conf'
- 'etc/bandwidthd/bandwidthd-webui.conf')
+ 'etc/bandwidthd/Caddyfile')
build() {
cd ${_reponame}
@@ -28,6 +28,8 @@ build() {
}
package() {
+ depends+=(caddy)
+
cd ${_reponame}
meson install -C build --destdir "${pkgdir}"