summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2018-11-06 18:43:30 -0500
committerStorm Dragon2018-11-06 18:43:30 -0500
commit6868f9b63d4ac375734784fede852289facdca4e (patch)
treeae931747a19d4ed1d80464d9357974016eed4dcb
downloadaur-6868f9b63d4ac375734784fede852289facdca4e.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd43ac8552da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Nov 6 23:43:09 UTC 2018
+pkgbase = barnard-git
+ pkgdesc = A command line mumble client.
+ pkgver = 20181106
+ pkgrel = 1
+ url = https://github.com/layeh/barnard
+ arch = armv7h
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = go
+ depends = openal
+ depends = opus
+ options = !strip
+ options = !emptydirs
+
+pkgname = barnard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93276ce13498
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Storm Dragon <storm_dragon@linux-a11y.org>
+
+pkgname="barnard-git"
+pkgver=20181106
+pkgrel=1
+pkgdesc="A command line mumble client."
+arch=('armv7h' 'x86_64')
+url="https://github.com/layeh/barnard"
+license=('GPL2')
+depends=('openal' 'opus')
+makedepends=('git' 'go')
+options=('!strip' '!emptydirs')
+_gourl=layeh.com/barnard
+
+build() {
+ GOPATH="$srcdir" go get -fix -v -x -u ${_gourl}
+}
+
+check() {
+ GOPATH="$GOPATH:$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -p -m755 "$srcdir/bin/"* "$pkgdir/usr/bin"
+
+ #mkdir -p "$pkgdir/$GOPATH"
+ #cp -Rv --preserve=timestamps "$srcdir/"{src,pkg} "$pkgdir/$GOPATH"
+
+}
+
+# vim:set ts=2 sw=2 et: