summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2018-06-18 12:38:41 +0100
committerCharles Bos2018-06-18 12:38:41 +0100
commit9964040b1f60cbd72a51a0fd3ec6c6c378e10406 (patch)
treed8a019e78d3ea5291c7592a3c0a722d2f4458860
parent632e979af40871b4f7a4f12c9d3d3e2fd8d97406 (diff)
downloadaur-9964040b1f60cbd72a51a0fd3ec6c6c378e10406.tar.gz
Use github as homepage because netdirect website no longer exists. also use github as source location instead of sourceforge. fix an error in the build relating to iterators
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--iterator-buildfix.patch27
3 files changed, 45 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4289160878f1..17a0f05e4247 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sat Jun 17 10:21:18 UTC 2017
pkgbase = barry
pkgdesc = Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices.
pkgver = 0.18.5
- pkgrel = 4
- url = http://www.netdirect.ca/software/packages/barry
+ pkgrel = 5
+ url = https://github.com/NetDirect/barry
arch = i686
arch = x86_64
license = GPL
@@ -19,16 +17,18 @@ pkgbase = barry
optdepends = fuse2: for mounting the BB database with bfuse
optdepends = ppp: for tethering with pppob
options = !libtool
- source = http://sourceforge.net/projects/barry/files/barry/barry-0.18.4/sources/debian/barry_0.18.5.orig.tar.gz
+ source = https://github.com/NetDirect/barry/archive/barry-0.18.5.tar.gz
source = barry.desktop
source = fix-sizeof-use.patch
source = wx3.0-compat.patch
source = c++11.patch
- sha256sums = 66cd913bcfcb5dc0fc3dfcbe8c375845d51649d573c321acba46b96b1bc0059e
+ source = iterator-buildfix.patch
+ sha256sums = cfe5224c34b25575543bbdeebf979074f76ccc7d37116f15aef20509e6c06c91
sha256sums = aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21
sha256sums = d1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e
sha256sums = d89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3
sha256sums = bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c
+ sha256sums = 690d6d9cdd5f84ac120e5e2a0c974916217a059c25ad08dd1b45b33d858993ad
pkgname = barry
diff --git a/PKGBUILD b/PKGBUILD
index ff12797eb080..cdafc955c249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,30 @@
pkgname=barry
pkgver=0.18.5
-pkgrel=4
+pkgrel=5
pkgdesc="Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices."
-url=http://www.netdirect.ca/software/packages/barry
+url=https://github.com/NetDirect/barry
license=('GPL')
arch=('i686' 'x86_64')
depends=('libusb' 'zlib' 'libglademm' 'libtar' 'libxml++2.6' 'wxgtk2' 'sdl' 'libgcal')
optdepends=('fuse2: for mounting the BB database with bfuse'
'ppp: for tethering with pppob')
options=('!libtool')
-source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-0.18.4/sources/debian/${pkgname}_${pkgver}.orig.tar.gz"
+source=("https://github.com/NetDirect/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.desktop"
"fix-sizeof-use.patch"
"wx3.0-compat.patch"
- "c++11.patch")
-sha256sums=('66cd913bcfcb5dc0fc3dfcbe8c375845d51649d573c321acba46b96b1bc0059e'
+ "c++11.patch"
+ "iterator-buildfix.patch")
+sha256sums=('cfe5224c34b25575543bbdeebf979074f76ccc7d37116f15aef20509e6c06c91'
'aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21'
'd1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e'
'd89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3'
- 'bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c')
+ 'bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c'
+ '690d6d9cdd5f84ac120e5e2a0c974916217a059c25ad08dd1b45b33d858993ad')
prepare() {
+ mv ${srcdir}/${pkgname}-${pkgname}-${pkgver} ${srcdir}/${pkgname}-${pkgver}
cd ${srcdir}/${pkgname}-${pkgver}
# Debian patches
@@ -34,6 +37,9 @@ prepare() {
# C++11 compatibility
patch -Np1 -i "${srcdir}/c++11.patch"
+ # Fix build failure for functions that return reverse iterators
+ patch -Np1 -i "${srcdir}/iterator-buildfix.patch"
+
autoreconf -fi
}
diff --git a/iterator-buildfix.patch b/iterator-buildfix.patch
new file mode 100644
index 000000000000..9089489db68c
--- /dev/null
+++ b/iterator-buildfix.patch
@@ -0,0 +1,27 @@
+diff -Nur original/desktop/src/optout.h modified/desktop/src/optout.h
+--- original/desktop/src/optout.h 2013-11-17 23:56:58.000000000 +0000
++++ modified/desktop/src/optout.h 2018-06-18 12:11:40.870542851 +0100
+@@ -92,6 +92,8 @@
+ typedef std::vector<Element*> container_type;
+ typedef container_type::iterator iterator;
+ typedef container_type::const_iterator const_iterator;
++ typedef container_type::reverse_iterator reverse_iterator;
++ typedef container_type::const_reverse_iterator const_reverse_iterator;
+ typedef container_type::size_type size_type;
+
+ private:
+@@ -134,10 +136,10 @@
+ const_iterator begin() const { return m_con.begin(); }
+ iterator end() { return m_con.end(); }
+ const_iterator end() const { return m_con.end(); }
+- iterator rbegin() { return m_con.rbegin(); }
+- const_iterator rbegin() const { return m_con.rbegin(); }
+- iterator rend() { return m_con.rend(); }
+- const_iterator rend() const { return m_con.rend(); }
++ reverse_iterator rbegin() { return m_con.rbegin(); }
++ const_reverse_iterator rbegin() const { return m_con.rbegin(); }
++ reverse_iterator rend() { return m_con.rend(); }
++ const_reverse_iterator rend() const { return m_con.rend(); }
+
+ // since iterators hold Element* pointers, these functions
+ // are just a helpful dynamic cast aid