summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2018-07-05 12:28:35 +0100
committerCharles Bos2018-07-05 12:28:35 +0100
commitb9eba2f06b8889ce283a94368dc6302ee7eecb64 (patch)
tree525ad481911c01a90f60abc4dd9a4e3402f12e6a
parent9964040b1f60cbd72a51a0fd3ec6c6c378e10406 (diff)
downloadaur-b9eba2f06b8889ce283a94368dc6302ee7eecb64.tar.gz
Disable compilation of the barrydesktop control panel, add desktop file for the barrybackup gui
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--barrybackup.desktop7
-rw-r--r--barrydesktop.desktop (renamed from barry.desktop)0
4 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17a0f05e4247..c458feda7c6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = barry
pkgdesc = Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices.
pkgver = 0.18.5
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/NetDirect/barry
arch = i686
arch = x86_64
@@ -18,13 +18,15 @@ pkgbase = barry
optdepends = ppp: for tethering with pppob
options = !libtool
source = https://github.com/NetDirect/barry/archive/barry-0.18.5.tar.gz
- source = barry.desktop
+ source = barrydesktop.desktop
+ source = barrybackup.desktop
source = fix-sizeof-use.patch
source = wx3.0-compat.patch
source = c++11.patch
source = iterator-buildfix.patch
sha256sums = cfe5224c34b25575543bbdeebf979074f76ccc7d37116f15aef20509e6c06c91
sha256sums = aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21
+ sha256sums = 1c6ecd68977da4a3184c3e6d4bea36e4c40949d6bf7bb4ad8717aa6c19fed4fa
sha256sums = d1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e
sha256sums = d89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3
sha256sums = bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c
diff --git a/PKGBUILD b/PKGBUILD
index cdafc955c249..bc6cb2461d0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=barry
pkgver=0.18.5
-pkgrel=5
+pkgrel=6
pkgdesc="Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices."
url=https://github.com/NetDirect/barry
license=('GPL')
@@ -14,13 +14,15 @@ optdepends=('fuse2: for mounting the BB database with bfuse'
'ppp: for tethering with pppob')
options=('!libtool')
source=("https://github.com/NetDirect/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
- "${pkgname}.desktop"
+ "barrydesktop.desktop"
+ "barrybackup.desktop"
"fix-sizeof-use.patch"
"wx3.0-compat.patch"
"c++11.patch"
"iterator-buildfix.patch")
sha256sums=('cfe5224c34b25575543bbdeebf979074f76ccc7d37116f15aef20509e6c06c91'
'aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21'
+ '1c6ecd68977da4a3184c3e6d4bea36e4c40949d6bf7bb4ad8717aa6c19fed4fa'
'd1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e'
'd89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3'
'bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c'
@@ -51,7 +53,7 @@ build() {
./configure --prefix=/usr --libexec=/usr/lib --sbindir=/usr/bin \
--enable-gui \
- --enable-desktop \
+ --disable-desktop \
--without-guisu
make
@@ -72,5 +74,8 @@ package() {
cp ./desktop/images/barry_logo_icon.xpm ${pkgdir}/usr/share/pixmaps
mkdir -p ${pkgdir}/usr/share/applications
- cp ../barry.desktop ${pkgdir}/usr/share/applications
+ # We are no longer compiling barrydesktop so there's no need to install the
+ # desktop entry file
+ # cp ../barrydesktop.desktop ${pkgdir}/usr/share/applications
+ cp ../barrybackup.desktop ${pkgdir}/usr/share/applications
}
diff --git a/barrybackup.desktop b/barrybackup.desktop
new file mode 100644
index 000000000000..849b68585e88
--- /dev/null
+++ b/barrybackup.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Barry Backup
+Comment=Graphical backup and restore utility for BlackBerry ™ devices.
+Type=Application
+Exec=barrybackup
+Icon=barry_logo_icon
+Categories=Application;Utility;
diff --git a/barry.desktop b/barrydesktop.desktop
index 4274a3afa665..4274a3afa665 100644
--- a/barry.desktop
+++ b/barrydesktop.desktop