summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Holme2022-03-16 10:22:42 +0100
committerChristian Holme2022-03-16 10:22:42 +0100
commit834b385a5d4797c4bc08ec92c29be04e0af5e65d (patch)
tree1a49a85aa68189b2cb4a13af7cddd70e7fde97f0
parent9a4f689ca80aa96081e60c009d19bc5f4b4e0470 (diff)
downloadaur-834b385a5d4797c4bc08ec92c29be04e0af5e65d.tar.gz
remove gcc10, add gcc>=11.2.0
11.2.0 fixes the compilation problem which made us use gcc10
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bd816dca721..2d84b11e23bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = bart-git
pkgdesc = Berkeley Advanced Reconstruction Toolbox (BART) for Computational Magnetic Resonance Imaging
- pkgver = 0.7.00.r130.gdd40a4d
+ pkgver = 0.7.00.r358.ge35c79c
pkgrel = 1
url = https://mrirecon.github.io/bart/
arch = x86_64
license = BSD
makedepends = git
- depends = gcc10
- depends = gcc10-libs
+ depends = gcc>=11.2.0
depends = openblas-lapack
depends = fftw
depends = libpng
diff --git a/PKGBUILD b/PKGBUILD
index 549ebdd84e89..217af2009cf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=bart-git
_pkgname=bart
-pkgver=0.7.00.r130.gdd40a4d
+pkgver=0.7.00.r358.ge35c79c
pkgrel=1
pkgdesc="Berkeley Advanced Reconstruction Toolbox (BART) for Computational Magnetic Resonance Imaging"
arch=('x86_64')
url="https://mrirecon.github.io/bart/"
license=('BSD')
makedepends=('git')
-depends=('gcc10' 'gcc10-libs' 'openblas-lapack' 'fftw' 'libpng')
+depends=('gcc>=11.2.0' 'openblas-lapack' 'fftw' 'libpng')
optdepends=('octave' 'python3')
source=('bart::git+https://github.com/mrirecon/bart.git')
sha512sums=('SKIP')
@@ -26,16 +26,13 @@ pkgver() {
build() {
cd "$_pkgname"
- # Add linking flag, seems needed for Arch. Will open PR / issue upstream
- #sed -i 's;BLAS_L := -L$(BLAS_BASE)/lib -llapacke -lblas;BLAS_L := -L$(BLAS_BASE)/lib -llapacke -lopenblas -lcblas;' Makefile
-
- make CC=gcc-10
- make CC=gcc-10 doc/commands.txt
+ make
+ make doc/commands.txt
}
package() {
cd "$_pkgname"
- make CC=gcc-10 PREFIX="$pkgdir"/usr install
+ make PREFIX="$pkgdir"/usr install
# Also install the libs, the viewer needs this and its not done by the Makefile atm
install -d "$pkgdir"/usr/lib/bart