summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Holme2023-06-15 15:19:49 +0200
committerChristian Holme2023-06-15 15:19:49 +0200
commitbd37545b0c731dcb07ae90ea76175d8654eebc86 (patch)
treee2e1def2042d21389cdc93c149abc02729381bb8
parent5cb9d5fa56f331092b63f833329cb08bd5f0fd60 (diff)
downloadaur-bd37545b0c731dcb07ae90ea76175d8654eebc86.tar.gz
handle conflicts with 'provides', overwrite symlink
overwriting the symlink is needed for repeated builds
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e03985f070da..2189b24f54ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = bart-git
depends = libpng
optdepends = octave
optdepends = python3
+ provides = bart
source = bart::git+https://github.com/mrirecon/bart.git
source = Makefile.local
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c05a95d1af62..86f0e73adadd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,6 +16,7 @@ source=('bart::git+https://github.com/mrirecon/bart.git'
'Makefile.local')
sha512sums=('SKIP'
'4ab4bb30e696dd262ecf59a64ec2ae5fa8f4832153816b4966c6af6e33fcf3981a5a4083d963cd3e470cd6000df32bfff4db146e9e34672f94962b5b329f4846')
+provides=('bart')
pkgver() {
cd "$_pkgname"
@@ -29,7 +30,7 @@ prepare() {
cd "$_pkgname"
# set path for openblas/lapacke/cblas headers
- ln -s "${srcdir}/Makefile.local"
+ ln -sf "${srcdir}/Makefile.local"
}