summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenton Liu2017-09-06 19:29:12 -0400
committerDenton Liu2017-09-06 19:29:12 -0400
commit2177702b5e8cd69fb94263ffdd49aac5cfb774ca (patch)
tree54cd95833b041489e0109fad96dae369ed4e1cfc
downloadaur-based-connect-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9f331da2af2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Sep 6 23:29:12 UTC 2017
+pkgbase = based-connect-git
+ pkgdesc = A reverse-engineered Bose Connect imitation program for Linux.
+ pkgver = r79.2f5c7ff
+ pkgrel = 1
+ url = https://github.com/Denton-L/based-connect
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = bluez-libs
+ provides = based-connect
+ conflicts = based-connect
+ source = git+https://github.com/Denton-L/based-connect.git
+ md5sums = SKIP
+
+pkgname = based-connect-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb2324607562
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+based-connect-git-*.xz
+based-connect/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cb357fe638f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Denton Liu <liu.denton@gmail.com>
+
+pkgname=based-connect-git
+_gitname="${pkgname%-git}"
+pkgver=r79.2f5c7ff
+pkgrel=1
+pkgdesc='A reverse-engineered Bose Connect imitation program for Linux.'
+arch=('i686' 'x86_64')
+url='https://github.com/Denton-L/based-connect'
+license=('GPL3')
+depends=('bluez-libs')
+makedepends=('git')
+provides=("$_gitname")
+conflicts=("$_gitname")
+source=('git+https://github.com/Denton-L/based-connect.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}