summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2016-10-30 00:09:41 -0400
committerJames P. Harvey2016-10-30 00:09:41 -0400
commita312d0ce997d46889d32df661f4026cc8d47c746 (patch)
treed91734bd92911abaa25384952ddf8278fbc7270f
parent43ceb72bd9a9819b6b6453b6f8a43e0bcb7d34c2 (diff)
downloadaur-a312d0ce997d46889d32df661f4026cc8d47c746.tar.gz
Upstream released 2.6.1. Updated maintainer's default arch theme. New symbols are more intuitive (to me anyway.) Staged files are pending, so ellipsis. Changed files represented by delta symbol. Untracked files represented by the exists symbol. Stashed files represented by a question mark, since their future is somewhat unknown. Also noted .install file for how to change a ~/.gitconfig to make 'git status' colors match the Default_Arch theme.
-rw-r--r--.SRCINFO8
-rw-r--r--Default_Arch.bgptheme9
-rw-r--r--PKGBUILD6
-rw-r--r--bash-git-prompt.install12
4 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41bb8580e877..22a1e708d168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Aug 18 00:53:08 UTC 2016
+# Sun Oct 30 04:07:18 UTC 2016
pkgbase = bash-git-prompt
pkgdesc = Informative git prompt for bash and fish
- pkgver = 2.5.1
+ pkgver = 2.6.1
pkgrel = 1
url = https://github.com/magicmonty/bash-git-prompt
install = bash-git-prompt.install
@@ -15,8 +15,8 @@ pkgbase = bash-git-prompt
source = bash-git-prompt.install
source = Default_Arch.bgptheme
md5sums = SKIP
- md5sums = db6f83999124b7fa660310a8d6624f70
- md5sums = 879555792d1b4c0ddef7cd81b0a3e35c
+ md5sums = 990d3a7ef8a21b83f0d1e90d9ef1a5b7
+ md5sums = af064330b3a579ec6efd2e018e6829df
pkgname = bash-git-prompt
diff --git a/Default_Arch.bgptheme b/Default_Arch.bgptheme
index cafb7f846a1e..cbd8861f9ba2 100644
--- a/Default_Arch.bgptheme
+++ b/Default_Arch.bgptheme
@@ -4,9 +4,12 @@
override_git_prompt_colors() {
GIT_PROMPT_THEME_NAME="Default Arch"
- GIT_PROMPT_CONFLICTS="${Red}✖"
- GIT_PROMPT_CHANGED="${Blue}✚"
- GIT_PROMPT_STASHED="${BoldBlue}⚑"
+ GIT_PROMPT_SEPARATOR=" "
+ GIT_PROMPT_STAGED="${Green}…"
+ GIT_PROMPT_CONFLICTS="${Yellow}✘"
+ GIT_PROMPT_CHANGED="${Red}Δ"
+ GIT_PROMPT_UNTRACKED="${Cyan}∃"
+ GIT_PROMPT_STASHED="${BoldBlack}?"
GIT_PROMPT_SYMBOLS_AHEAD="↑"
GIT_PROMPT_SYMBOLS_BEHIND="↓"
GIT_PROMPT_END_USER=" \n${White}[\u@\h] ${Time12a}${ResetColor} $ "
diff --git a/PKGBUILD b/PKGBUILD
index e22284ff861f..6c0d40a5b531 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# * No namcap warnings or errors
pkgname=bash-git-prompt
-pkgver=2.5.1
+pkgver=2.6.1
pkgrel=1
pkgdesc="Informative git prompt for bash and fish"
arch=('any')
@@ -16,8 +16,8 @@ source=("git+https://github.com/magicmonty/${pkgname}"
'bash-git-prompt.install'
'Default_Arch.bgptheme')
md5sums=('SKIP'
- 'db6f83999124b7fa660310a8d6624f70'
- '879555792d1b4c0ddef7cd81b0a3e35c')
+ '990d3a7ef8a21b83f0d1e90d9ef1a5b7'
+ 'af064330b3a579ec6efd2e018e6829df')
install='bash-git-prompt.install'
prepare() {
diff --git a/bash-git-prompt.install b/bash-git-prompt.install
index ef7e4ffecdf1..33c1e85df7cc 100644
--- a/bash-git-prompt.install
+++ b/bash-git-prompt.install
@@ -13,6 +13,18 @@ post_install() {
GIT_PROMPT_THEME=Default_Arch
source /usr/lib/bash-git-prompt/gitprompt.sh
fi
+
+ NOTE: To have the colors shown by 'git status' match the Default_Arch theme,
+ add the following to your ~/.gitconfig:
+
+ [color "status"]
+ branch = magenta
+ untracked = cyan
+ unmerged = yellow
+
+ And if you want boilerplate to be less prominent, also:
+
+ header = bold black
"
}