summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtto Sabart2020-07-24 09:50:41 +0200
committerOtto Sabart2020-07-24 09:50:41 +0200
commitc860a7bf447875534776297278cb2bddb297d9d4 (patch)
tree2b8bfa35a89ddb0745669674b362f6737393115b
parentbb49bbbdd4b2f5e31e6fe7542df2de1c88291d64 (diff)
downloadaur-bash-supergenpass.tar.gz
do not use legacy git download method
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
2 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac7573047486..70bda232f44b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bash-supergenpass
pkgdesc = Bash implementation of Super Gen Pass script
- pkgver = 20130529
+ pkgver = 20.e5d96599b65d
pkgrel = 1
url = http://github.com/lanzz/bash-supergenpass
arch = any
@@ -9,6 +9,8 @@ pkgbase = bash-supergenpass
depends = openssl
provides = supergenpass
conflicts = perl-supergenpass
+ source = bash-supergenpass::git+https://github.com/lanzz/bash-supergenpass.git
+ sha512sums = SKIP
pkgname = bash-supergenpass
diff --git a/PKGBUILD b/PKGBUILD
index 92271fe09e5f..5c160f09a16c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,28 @@
# Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot].com
-
+
pkgname=bash-supergenpass
-pkgver=20130529
+_gitname=${pkgname%-git*}
+pkgver=20.e5d96599b65d
pkgrel=1
pkgdesc="Bash implementation of Super Gen Pass script"
url="http://github.com/lanzz/bash-supergenpass"
arch=('any')
license=('custom')
install=
-source=()
depends=('bash' 'openssl')
optdepends=()
conflicts=('perl-supergenpass')
provides=('supergenpass')
makedepends=()
+source=("$_gitname::git+https://github.com/lanzz/${_gitname}.git")
+sha512sums=('SKIP')
-_gitname="bash-supergenpass"
-_gitroot="git://github.com/lanzz/${_gitname}.git"
-
-
-build() {
- cd $srcdir
- msg "Connecting to GIT (${_gitroot}) ..."
-
- if [ -d $_gitname ]; then
- cd $_gitname && git pull origin
- msg "The local files of ${_gitname} were updated."
- else
- git clone $_gitroot $_gitname
- fi
-
- msg "GIT checkout done or server timeout"
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
}
-
+
+
package() {
cd $srcdir/${_gitname}
mkdir -p $pkgdir/usr/bin