diff options
author | Otto Sabart | 2020-07-24 09:50:41 +0200 |
---|---|---|
committer | Otto Sabart | 2020-07-24 09:50:41 +0200 |
commit | c860a7bf447875534776297278cb2bddb297d9d4 (patch) | |
tree | 2b8bfa35a89ddb0745669674b362f6737393115b | |
parent | bb49bbbdd4b2f5e31e6fe7542df2de1c88291d64 (diff) | |
download | aur-bash-supergenpass.tar.gz |
do not use legacy git download method
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 30 |
2 files changed, 13 insertions, 21 deletions
@@ -1,6 +1,6 @@ pkgbase = bash-supergenpass pkgdesc = Bash implementation of Super Gen Pass script - pkgver = 20130529 + pkgver = 20.e5d96599b65d pkgrel = 1 url = http://github.com/lanzz/bash-supergenpass arch = any @@ -9,6 +9,8 @@ pkgbase = bash-supergenpass depends = openssl provides = supergenpass conflicts = perl-supergenpass + source = bash-supergenpass::git+https://github.com/lanzz/bash-supergenpass.git + sha512sums = SKIP pkgname = bash-supergenpass @@ -1,38 +1,28 @@ # Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot].com - + pkgname=bash-supergenpass -pkgver=20130529 +_gitname=${pkgname%-git*} +pkgver=20.e5d96599b65d pkgrel=1 pkgdesc="Bash implementation of Super Gen Pass script" url="http://github.com/lanzz/bash-supergenpass" arch=('any') license=('custom') install= -source=() depends=('bash' 'openssl') optdepends=() conflicts=('perl-supergenpass') provides=('supergenpass') makedepends=() +source=("$_gitname::git+https://github.com/lanzz/${_gitname}.git") +sha512sums=('SKIP') -_gitname="bash-supergenpass" -_gitroot="git://github.com/lanzz/${_gitname}.git" - - -build() { - cd $srcdir - msg "Connecting to GIT (${_gitroot}) ..." - - if [ -d $_gitname ]; then - cd $_gitname && git pull origin - msg "The local files of ${_gitname} were updated." - else - git clone $_gitroot $_gitname - fi - - msg "GIT checkout done or server timeout" +pkgver() { + cd "$srcdir/$_gitname" + echo $(git rev-list --count master).$(git rev-parse --short master) } - + + package() { cd $srcdir/${_gitname} mkdir -p $pkgdir/usr/bin |