summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2021-02-08 21:53:09 +0800
committerzhullyb2021-02-08 21:53:09 +0800
commit0d74bbddd9a75f3c5ef1cc390c2c7577083ecf84 (patch)
treefadbf84faf549fdec17d779538e73b37225fead7
downloadaur-bash2048.tar.gz
First Version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26486d65734
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bash2048
+ pkgdesc = Bash implementation of 2048 game
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/mydzor/bash2048
+ arch = any
+ license = Unlicense
+ provides = bash2048
+ source = https://github.com/mydzor/bash2048/archive/1.0.tar.gz
+ md5sums = 7a8e083ef89d6fbc51a60ce6b6c41f89
+
+pkgname = bash2048
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..491bf34ba50d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: zhullyb <zhullyb@outlook.com>
+
+pkgname=bash2048
+pkgver=1.0
+pkgrel=1
+pkgdesc="Bash implementation of 2048 game"
+url="https://github.com/mydzor/bash2048"
+arch=('any')
+license=("Unlicense")
+depends=()
+provides=('bash2048')
+source=("https://github.com/mydzor/bash2048/archive/${pkgver}.tar.gz")
+
+md5sums=('7a8e083ef89d6fbc51a60ce6b6c41f89')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -D -m 755 bash2048.sh "$pkgdir/usr/bin/bash2048"
+ install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}