summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTommaso Sardelli2024-02-08 23:53:18 +0100
committerTommaso Sardelli2024-02-08 23:53:18 +0100
commit25ef765df98c4e981387f0dd83215390f051ffbd (patch)
treeae2f30c99771b295de4af12599e39e3cd9b50cf8
parent2de604d933da228248c993830cb06e88a068d811 (diff)
downloadaur-bashmarks-git.tar.gz
Switch to git+https protocol and include commit hash in package version
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e10ebb77f649..625c3f3ff045 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Mar 20 17:07:42 UTC 2016
pkgbase = bashmarks-git
pkgdesc = A shell script that allows you to save and jump to commonly used directories
- pkgver = 43
- pkgrel = 3
+ pkgver = r48.264952f
+ pkgrel = 1
url = https://github.com/huyng/bashmarks
install = bashmarks-git.install
arch = any
@@ -11,8 +9,7 @@ pkgbase = bashmarks-git
makedepends = git
provides = bashmarks
conflicts = bashmarks
- source = git://github.com/huyng/bashmarks.git
- md5sums = SKIP
+ source = git+https://github.com/huyng/bashmarks.git
+ sha512sums = SKIP
pkgname = bashmarks-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bf120dabbc4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.zst
+bashmarks
diff --git a/PKGBUILD b/PKGBUILD
index ef5e15df8c9f..d5a695ad342d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=bashmarks
pkgname=${_pkgname}-git
-pkgver=43
-pkgrel=3
+pkgver=r48.264952f
+pkgrel=1
pkgdesc='A shell script that allows you to save and jump to commonly used directories'
arch=('any')
url="https://github.com/huyng/${_pkgname}"
@@ -12,12 +12,15 @@ makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
install="$pkgname.install"
-source=("git://github.com/huyng/${_pkgname}.git")
-md5sums=('SKIP')
+source=("git+https://github.com/huyng/${_pkgname}.git")
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- git rev-list --count HEAD
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
}
package() {