summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Wisniewski2017-09-09 23:30:17 +0100
committerTomasz Wisniewski2017-09-09 23:30:17 +0100
commitc1f46a4ec5d6ee1078ae996dc286bd7fe0489ef4 (patch)
tree1d780defc4716c6f98a52336ea036684b50f75bb
downloadaur-bashnapi.tar.gz
Add initial version of the bashnapi AUR package
This commit adds the first version of the AUR package for bashnapi.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76b0c0f6a93b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = bashnapi
+ pkgdesc = bashnapi is a napiprojekt.pl bash client bundled with subotage - a universal subtitles format converter
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/dagon666/napi
+ arch = any
+ license = GPL
+ depends = bash
+ depends = coreutils
+ depends = sed
+ depends = gawk
+ depends = file
+ depends = cmake
+ depends = grep
+ depends = findutils
+ depends = wget
+ source = https://github.com/dagon666/napi/archive/v2.0.0.tar.gz
+ md5sums = c86efaa856f7e80e993456aff9ced322
+
+pkgname = bashnapi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43a738227226
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Tomasz Wisniewski <tomasz.wisni3wski@gmail.com>
+pkgname=bashnapi
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="bashnapi is a napiprojekt.pl bash client bundled with subotage - a universal subtitles format converter"
+arch=('any')
+url="https://github.com/dagon666/napi"
+license=('GPL')
+groups=()
+depends=('bash' 'coreutils' 'sed' 'gawk' 'file' 'cmake' 'grep' 'findutils' 'wget')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/dagon666/napi/archive/v${pkgver}.tar.gz")
+noextract=()
+md5sums=('c86efaa856f7e80e993456aff9ced322')
+
+build() {
+ builddir="${pkgname}-${pkgver}-build"
+ srcdir="napi-${pkgver}"
+ mkdir -p "$builddir"
+ cd "$builddir"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" ../${srcdir}
+ make
+}
+
+package() {
+ builddir="${pkgname}-${pkgver}-build"
+ cd "$builddir"
+ make install
+}