summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-21 09:39:41 +0100
committerJoan Bruguera2019-03-21 09:39:41 +0100
commit61b6d5a534f404c1778e25fa03fed55f978b0354 (patch)
tree7f60af3f0dd8ca7a7c77862ec79e3bef24777ffe
downloadaur-61b6d5a534f404c1778e25fa03fed55f978b0354.tar.gz
Initial version.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5034b2e706a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = basicanalysis
+ pkgdesc = Framework for automatic extraction of fundamental factors for Paraver traces (from BSC).
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
+ arch = any
+ license = LGPLv2.1
+ depends = python-scipy
+ depends = python-numpy
+ optdepends = gnuplot
+ source = https://ftp.tools.bsc.es/basicanalysis/basicanalysis-0.3.6-src.tar.bz2
+ sha512sums = 94fac4171454978c1f3a27ec29e0c407413008b491ffe9aed2f7915ef9e5d3f7b2cdbc155ba00aa3e426b261ca259e1c00b59ffdde941bbb6a3cc49194827897
+
+pkgname = basicanalysis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dee54bd644a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
+pkgname='basicanalysis'
+pkgdesc='Framework for automatic extraction of fundamental factors for Paraver traces (from BSC).'
+pkgver='0.3.6'
+pkgrel='1'
+arch=('any')
+url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
+license=('LGPLv2.1')
+depends=(python-scipy python-numpy)
+optdepends=(gnuplot)
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+sha512sums=(94fac4171454978c1f3a27ec29e0c407413008b491ffe9aed2f7915ef9e5d3f7b2cdbc155ba00aa3e426b261ca259e1c00b59ffdde941bbb6a3cc49194827897)
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d -m755 "$pkgdir/usr/lib/basicanalysis/cfgs/"
+ install -D -m755 "modelfactors.py" "$pkgdir/usr/lib/basicanalysis/"
+ find "cfgs" -type f -exec install -D -m644 "{}" "$pkgdir/usr/lib/basicanalysis/cfgs/" \;
+
+ mkdir -p -m755 "$pkgdir/usr/bin"
+ ln -s "/usr/lib/basicanalysis/modelfactors.py" "$pkgdir/usr/bin/modelfactors.py"
+} \ No newline at end of file