summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-12-10 21:09:10 +0100
committerJoan Bruguera2019-12-10 21:09:10 +0100
commitb56ec57def1ae1cf29d0f844af9deecc2b084f95 (patch)
tree11b0b149eef2d7d5f834676b258ab9887f69e583
parent835b4b37bdedec2a1778877cb4cf213ee7c8d2e6 (diff)
downloadaur-b56ec57def1ae1cf29d0f844af9deecc2b084f95.tar.gz
Upgrade tracking to the latest version. Additionally, change BSC package versioning numbers, in order to include the year in the pkgver. This is to deal with the fact that multiple, different tallbars are routinely released for the same version number. Up until now, this was handled by bumping pkgrel, but this is not the correct way to handle this, since it's not just a rebuild, but just the upstream code changed.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afbdbf342a8f..31437b1a19dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = basicanalysis
pkgdesc = Framework for automatic extraction of fundamental factors for Paraver traces (from BSC).
- pkgver = 0.3.6
- pkgrel = 3
+ pkgver = 0.3.6.20180531
+ pkgrel = 1
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = any
license = LGPL2.1
diff --git a/PKGBUILD b/PKGBUILD
index eb19fa9fa9cd..41bcfbb35456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname='basicanalysis'
pkgdesc='Framework for automatic extraction of fundamental factors for Paraver traces (from BSC).'
-pkgver='0.3.6'
-pkgrel='3'
+pkgver='0.3.6.20180531'
+pkgrel='1'
arch=('any')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(python python-scipy python-numpy)
optdepends=('gnuplot: For drawing the generated plots')
-source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2")
sha512sums=(94fac4171454978c1f3a27ec29e0c407413008b491ffe9aed2f7915ef9e5d3f7b2cdbc155ba00aa3e426b261ca259e1c00b59ffdde941bbb6a3cc49194827897)
package() {
# Install script and configurations in /usr/lib/basicanalysis
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-${pkgver%.*}"
install -d -m755 "$pkgdir/usr/lib/basicanalysis/cfgs/"
install -D -m755 "modelfactors.py" "$pkgdir/usr/lib/basicanalysis/"
find "cfgs" -type f -exec install -D -m644 "{}" "$pkgdir/usr/lib/basicanalysis/cfgs/" \;