summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMisaka135142022-02-10 22:06:48 +0800
committerMisaka135142022-02-10 22:06:48 +0800
commit276240e2a0867ed8f8e28677d1fb52c7a7e7eca2 (patch)
treef2b254a6cd7100a04df3cbdcab04ddf84fddf6e9
downloadaur-276240e2a0867ed8f8e28677d1fb52c7a7e7eca2.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
-rw-r--r--bbg.desktop11
-rwxr-xr-xbbg.sh3
-rw-r--r--icon.pngbin0 -> 116209 bytes
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b91769d29c42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = bbg-git
+ pkgdesc = A static blog generator built with electron
+ pkgver = 20220212.r0.d37787d
+ pkgrel = 1
+ url = https://github.com/baiyang-lzy/bbg
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = npm
+ depends = electron
+ depends = gtk3
+ depends = libxcb
+ provides = bbg
+ conflicts = bbg
+ source = bbg.sh
+ source = icon.png
+ source = bbg.desktop
+ source = bbg::git+https://github.com/baiyang-lzy/bbg.git
+ sha256sums = b24a2718e870311aa07ae4e1c106218a87042e76102023236c006558f727ea09
+ sha256sums = b2055c02386eacb33fff9f53b2c1bf099d49e4c63d016704a220e9108ded262f
+ sha256sums = f503d93639c1f4d4e050eceb11adf64d369908e5941cfdbda3af30b2f3c73d96
+ sha256sums = SKIP
+
+pkgname = bbg-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b82cf29f5a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Misaka13514 <Misaka13514 at gmail dot com>
+pkgname=bbg-git
+pkgver=20220212.r0.d37787d
+pkgrel=1
+pkgdesc="A static blog generator built with electron"
+arch=('any')
+url="https://github.com/baiyang-lzy/bbg"
+license=('GPL3')
+depends=('electron' 'gtk3' 'libxcb')
+makedepends=('git' 'npm')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(
+ 'bbg.sh'
+ 'icon.png'
+ 'bbg.desktop'
+ "${pkgname%-git}::git+${url}.git"
+)
+sha256sums=(
+ 'b24a2718e870311aa07ae4e1c106218a87042e76102023236c006558f727ea09'
+ 'b2055c02386eacb33fff9f53b2c1bf099d49e4c63d016704a220e9108ded262f'
+ 'f503d93639c1f4d4e050eceb11adf64d369908e5941cfdbda3af30b2f3c73d96'
+ 'SKIP'
+)
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ npm install
+ npm run package_linux
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "${pkgdir}/usr/lib/${pkgname%-git}"
+ install -Dm 755 bbg.sh "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm 644 "${pkgname%-git}/bbg-linux-x64/resources/app.asar" "${pkgdir}/usr/lib/${pkgname%-git}/app.asar"
+ install -Dm 644 bbg.desktop "${pkgdir}/usr/share/applications/${pkgname%-git}.desktop"
+ install -Dm 644 icon.png "${pkgdir}/usr/share/icons/${pkgname%-git}.png"
+}
diff --git a/bbg.desktop b/bbg.desktop
new file mode 100644
index 000000000000..7ce8a37a50fa
--- /dev/null
+++ b/bbg.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=bbg
+Comment=blog generator
+Keywords=
+Exec=/usr/bin/bbg
+TryExec=
+Terminal=false
+Icon=/usr/share/icons/bbg.png
+Type=Application
+StartupNotify=false
+Categories=Office
diff --git a/bbg.sh b/bbg.sh
new file mode 100755
index 000000000000..2ad3c30a18c2
--- /dev/null
+++ b/bbg.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec electron /usr/lib/bbg/app.asar "$@"
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..3cc17f45a98c
--- /dev/null
+++ b/icon.png
Binary files differ