summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-11-18 18:15:56 +0100
committerChristopher Arndt2022-11-18 18:15:56 +0100
commit0ccc51aab91dc479037db6a00a87ee64016c5bbd (patch)
treebecd9cddc09ccb957434845ce4c6edf96422c137
parent68baae23d1e37b7668d7fcfeffe0d5694fd8de9b (diff)
downloadaur-bchoppr-git.tar.gz
Cleaned up PKGBUILD
* Also install screenshot into doc dir * Add 'lv2-host' as optdpends * Remove redundant depends
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD50
2 files changed, 30 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a6f771d48bf..b50767af53ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bchoppr-git
pkgdesc = An audio stream chopping LV2 plugin (git version)
- pkgver = 1.8.0.r0.g7fb0af3
+ pkgver = 1.12.0.r0.gb355a1c
pkgrel = 1
url = https://github.com/sjaehn/BChoppr
arch = x86_64
@@ -12,13 +12,11 @@ pkgbase = bchoppr-git
makedepends = lv2
depends = cairo
depends = gcc-libs
- depends = glibc
- depends = libx11
+ optdepends = lv2-host: for loading the LV2 plugin
provides = bchoppr
- provides = bchoppr=1.8.0
+ provides = bchoppr=1.12.0
conflicts = bchoppr
- source = bchoppr::git+https://github.com/sjaehn/BChoppr
+ source = bchoppr::git+https://github.com/sjaehn/BChoppr.git
md5sums = SKIP
pkgname = bchoppr-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 03063ca92f2a..1a58a22ea0dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Milk Brewster (milkii on freenode irc)
# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
-_name="BChoppr"
-_pkgname="${_name,,}"
-_plugin_uri="https://www.jahnichen.de/plugins/lv2/${_name}"
-pkgname="${_pkgname}-git"
-pkgver=1.8.0.r0.g7fb0af3
+_name=BChoppr
+_pkgname=${_name,,}
+_plugin_uri="https://www.jahnichen.de/plugins/lv2/$_name"
+pkgname=$_pkgname-git
+pkgver=1.12.0.r0.gb355a1c
pkgrel=1
-pkgdesc="An audio stream chopping LV2 plugin (git version)"
-arch=('x86_64')
-url="https://github.com/sjaehn/${_name}"
-license=('GPL3')
-groups=('lv2-plugins' 'pro-audio')
-depends=('cairo' 'gcc-libs' 'glibc' 'libx11')
-makedepends=('git' 'lv2')
-checkdepends=('lv2lint')
-provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/sjaehn/${_name}")
+pkgdesc='An audio stream chopping LV2 plugin (git version)'
+arch=(x86_64)
+url='https://github.com/sjaehn/BChoppr'
+license=(GPL3)
+groups=(lv2-plugins pro-audio)
+depends=(cairo gcc-libs)
+makedepends=(git lv2)
+checkdepends=(lv2lint)
+optdepends=('lv2-host: for loading the LV2 plugin')
+provides=($_pkgname "$_pkgname=${pkgver//.r*/}")
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/sjaehn/$_name.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/$_pkgname"
+ cd $_pkgname
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -30,19 +31,20 @@ pkgver() {
}
build() {
- cd "${srcdir}/$_pkgname"
+ cd $_pkgname
make
}
check() {
- cd "${srcdir}/${_pkgname}"
- lv2lint -Mpack -I "${_name}.lv2/" "${_plugin_uri}"
+ cd $_pkgname
+ lv2lint -Mpack -I "$_name.lv2" "$_plugin_uri"
}
package() {
- cd "$_pkgname"
- make PREFIX="/usr" DESTDIR="$pkgdir/" install
- install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ cd $_pkgname
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ install -vDm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
+ install -vDm644 doc/*.png -t "$pkgdir"/usr/share/doc/$pkgname/doc
# Remove useless license file
- find "${pkgdir}/usr/lib/" -type f -iname "*LICENSE*" -delete
+ rm -f "$pkgdir"/usr/lib/vst/$_name.lv2/LICENSE
}