summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorz3ntu2016-01-07 13:22:18 +0100
committerz3ntu2016-01-07 13:22:18 +0100
commit703a2790b395f059d606f926e357100e4bab89ba (patch)
tree4b8052a964e57838f5ed7e8ab05d320124aec19b
downloadaur-703a2790b395f059d606f926e357100e4bab89ba.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65436d018852
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Jan 7 12:18:04 UTC 2016
+pkgbase = bcm2835
+ pkgdesc = C library for Raspberry Pi
+ pkgver = 1.49
+ pkgrel = 1
+ url = http://www.airspayce.com/mikem/bcm2835/
+ arch = armv6h
+ arch = x86_64
+ license = GPL
+ provides = bcm2835
+ source = http://www.airspayce.com/mikem/bcm2835/bcm2835-1.49.tar.gz
+ md5sums = 1033886435a1d226124b075fc1291f85
+
+pkgname = bcm2835
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67e2351c31cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+pkgname=bcm2835
+pkgver=1.49
+pkgrel=1
+pkgdesc="C library for Raspberry Pi"
+arch=('armv6h' 'x86_64')
+url="http://www.airspayce.com/mikem/bcm2835/"
+license=('GPL')
+depends=()
+makedepends=()
+optdepends=()
+provides=('bcm2835')
+install=
+changelog=
+source=("http://www.airspayce.com/mikem/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('1033886435a1d226124b075fc1291f85')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# export FAKEROOTKEY=fake
+# make check
+#}
+# Disabled because the check needs root permission
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}