summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorz3ntu2016-01-07 13:34:40 +0100
committerz3ntu2016-01-07 13:34:40 +0100
commitb4e9ea2012218dd44157a3cf9fc109f83876fc6d (patch)
tree61af6a15af351792bf286a5a822a3410e9d8c726
parent703a2790b395f059d606f926e357100e4bab89ba (diff)
downloadaur-b4e9ea2012218dd44157a3cf9fc109f83876fc6d.tar.gz
Cleanup & add armv7h architecture for the raspberry pi 2 (only tested on the Raspberry Pi Model B (1))
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65436d018852..9c86d6ba27ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Thu Jan 7 12:18:04 UTC 2016
+# Thu Jan 7 12:34:23 UTC 2016
pkgbase = bcm2835
- pkgdesc = C library for Raspberry Pi
+ pkgdesc = C library for the Raspberry Pi
pkgver = 1.49
pkgrel = 1
url = http://www.airspayce.com/mikem/bcm2835/
arch = armv6h
- arch = x86_64
- license = GPL
+ arch = armv7h
+ license = GPL2
provides = bcm2835
source = http://www.airspayce.com/mikem/bcm2835/bcm2835-1.49.tar.gz
md5sums = 1033886435a1d226124b075fc1291f85
diff --git a/PKGBUILD b/PKGBUILD
index 67e2351c31cf..6bdf4b2cf76a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,23 @@
pkgname=bcm2835
pkgver=1.49
pkgrel=1
-pkgdesc="C library for Raspberry Pi"
-arch=('armv6h' 'x86_64')
+pkgdesc="C library for the Raspberry Pi"
+arch=('armv6h' 'armv7h')
url="http://www.airspayce.com/mikem/bcm2835/"
-license=('GPL')
-depends=()
-makedepends=()
-optdepends=()
+license=('GPL2')
provides=('bcm2835')
-install=
-changelog=
source=("http://www.airspayce.com/mikem/$pkgname/$pkgname-$pkgver.tar.gz")
md5sums=('1033886435a1d226124b075fc1291f85')
-
build() {
cd "$pkgname-$pkgver"
./configure --prefix=/usr
make
}
-
#check() {
# cd "$pkgname-$pkgver"
-# export FAKEROOTKEY=fake
# make check
#}
-# Disabled because the check needs root permission
-
+# Disabled because the check needs root permission (I don't know how to fix this)
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install