summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-12-23 15:05:25 -0300
committerHugo Osvaldo Barrera2015-12-23 15:05:25 -0300
commite738c3b8442bcc74dc9c9fe879ed80bd01dad8c4 (patch)
treeb25696350ba813d36bd3b0d7da2b820ed5f85955
parent4af664df7e26a3ed74baf301db5124362427172f (diff)
downloadaur-e738c3b8442bcc74dc9c9fe879ed80bd01dad8c4.tar.gz
Depend on bcwc-pcie-firmware rather than bundle it
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91dcaa9bcc17..b95a2857abde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Dec 23 16:00:15 UTC 2015
+# Wed Dec 23 18:05:14 UTC 2015
pkgbase = bcwc-pcie-git
pkgdesc = Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam.
pkgver = latest
@@ -12,10 +12,9 @@ pkgbase = bcwc-pcie-git
makedepends = linux-headers
makedepends = git
depends = kmod
+ depends = bcwc-pcie-firmware
source = bcwc-pcie-git::git+https://github.com/patjak/bcwc_pcie.git
- source = firmware.bin::https://github.com/patjak/bcwc_pcie/wiki/Get-Started
md5sums = SKIP
- md5sums = 4e1d11e205e5c55d128efa0029b268fe
pkgname = bcwc-pcie-git
diff --git a/PKGBUILD b/PKGBUILD
index 20b807ed136f..14afe49db222 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,12 @@ pkgdesc="Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam."
arch=('x86_64')
url="https://github.com/patjak/bcwc_pcie"
license=('unknown')
-depends=('kmod')
+depends=('kmod' 'bcwc-pcie-firmware')
makedepends=('linux' 'linux-headers' 'git')
install="$pkgname.install"
-# firmware.bin needs to be extracted from OS X manually.
-source=("$pkgname::git+https://github.com/patjak/bcwc_pcie.git"
- "firmware.bin::https://github.com/patjak/bcwc_pcie/wiki/Get-Started")
-md5sums=('SKIP'
- '4e1d11e205e5c55d128efa0029b268fe')
+source=("$pkgname::git+https://github.com/patjak/bcwc_pcie.git")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -35,6 +32,4 @@ package() {
KERNEL_VERSION=$(uname -r | cut -d '.' -f 1,2)
install -Dm 644 facetimehd.ko.gz \
"$pkgdir/usr/lib/modules/extramodules-${KERNEL_VERSION}-ARCH/facetimehd.ko.gz"
- install -Dm 644 "$srcdir"/firmware.bin \
- "$pkgdir/usr/lib/firmware/facetimehd/firmware.bin"
}