summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-29 21:43:15 +0200
committeroli2015-06-29 21:43:15 +0200
commit3dbc7c219a15978adec9b1eed587b926f54b572a (patch)
tree9508ef9c28a1385de7f642c80e8eb87b79505b0e
downloadaur-bdfedit.tar.gz
updated
-rw-r--r--.SRCINFO21
-rw-r--r--COPYING10
-rw-r--r--PKGBUILD33
-rw-r--r--bdfedit-1.3.diff47
-rw-r--r--bdfedit.desktop10
-rw-r--r--bdfedit.pngbin0 -> 2296 bytes
6 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..850108e43dbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = bdfedit
+ pkgdesc = A BDF font editor
+ pkgver = 1.3
+ pkgrel = 3
+ url = http://hea-www.harvard.edu/~fine/Tech/bdfedit.html
+ arch = any
+ license = custom
+ depends = tk>7.6
+ source = http://hea-www.harvard.edu/~fine/Tech/bdfedit1.3.tar.gz
+ source = bdfedit-1.3.diff
+ source = bdfedit.desktop
+ source = bdfedit.png
+ source = COPYING
+ sha256sums = ac5cfac845827b721af02791615363eae07b89cf290d12bd0734174fcc8ed0d6
+ sha256sums = 538e674dfca72c8486590bd2f741cc231f2762257d8970b72916843dab38bc51
+ sha256sums = 7ef8c9f9722f221546dc0af38f87c2381a48e2219573770629387f751270775b
+ sha256sums = 65c883f934a8a350605699e6ea8905e06c3a1f027ebd15a7a2b67a31a2792028
+ sha256sums = 1ebbeaca53852f9a5bd362fc6833be1b2b9f2c795a76c618d2034b3b328e0073
+
+pkgname = bdfedit
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..7704a22e96d4
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,10 @@
+bdfedit Version 1.3
+
+bdfedit Home page:
+http://hea-www.harvard.edu/~fine/Tech/bdfedit.html
+
+Copyright © 2000 Thomas A. Fine
+
+This distribution may be used and redistributed in whole or in part for
+any purpose provided only that notice of this license and the original
+author and copyright holder (Thomas A. Fine) is preserved.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..011a4ebf091c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: TDY <tdy@archlinux.info>
+# Contributor: skorpan <kristnjov__gmail>
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=bdfedit
+pkgver=1.3
+pkgrel=3
+pkgdesc="A BDF font editor"
+arch=('any')
+url="http://hea-www.harvard.edu/~fine/Tech/bdfedit.html"
+license=('custom')
+depends=('tk>7.6')
+source=(http://hea-www.harvard.edu/~fine/Tech/$pkgname$pkgver.tar.gz
+ $pkgname-$pkgver.diff $pkgname.desktop $pkgname.png COPYING)
+sha256sums=('ac5cfac845827b721af02791615363eae07b89cf290d12bd0734174fcc8ed0d6'
+ '538e674dfca72c8486590bd2f741cc231f2762257d8970b72916843dab38bc51'
+ '7ef8c9f9722f221546dc0af38f87c2381a48e2219573770629387f751270775b'
+ '65c883f934a8a350605699e6ea8905e06c3a1f027ebd15a7a2b67a31a2792028'
+ '1ebbeaca53852f9a5bd362fc6833be1b2b9f2c795a76c618d2034b3b328e0073')
+
+package() {
+ cd "$srcdir/$pkgname$pkgver"
+ patch -Np1 -i ../$pkgname-$pkgver.diff
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 completion.tcl "$pkgdir/usr/share/$pkgname/completion.tcl"
+ install -Dm644 $pkgname.samprc "$pkgdir/etc/bdfeditrc"
+ install -Dm644 $pkgname.help "$pkgdir/usr/share/doc/$pkgname/readme.txt"
+ install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 ../$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 ../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/bdfedit-1.3.diff b/bdfedit-1.3.diff
new file mode 100644
index 000000000000..d51b1232b905
--- /dev/null
+++ b/bdfedit-1.3.diff
@@ -0,0 +1,47 @@
+diff -Naur bdfedit1.3~/bdfedit bdfedit1.3/bdfedit
+--- bdfedit1.3~/bdfedit 2009-01-06 21:28:12.000000000 -0600
++++ bdfedit1.3/bdfedit 2009-01-06 21:28:17.000000000 -0600
+@@ -1,8 +1,8 @@
+-#!/opt/local/bin/wish -f
++#!/usr/bin/wish -f
+ #Fix the path above.
+
+ #Fix the path below.
+-source /home/fine/tcl/completion.tcl
++source /usr/share/bdfedit/completion.tcl
+
+ # TTD
+ # BACKUP FILE BEFORE SAVE!!!!
+@@ -2128,7 +2128,7 @@
+
+ proc readrc {} {
+ global env default
+- set rcfile $env(HOME)/.bdfeditrc
++ set rcfile /etc/bdfeditrc
+ if [file exists $rcfile] {
+ if [catch "source $rcfile" err] {
+ showmess "Error reading rc file ($rcfile):\n$err"
+diff -Naur bdfedit1.3~/bdfedit.samprc bdfedit1.3/bdfedit.samprc
+--- bdfedit1.3~/bdfedit.samprc 2009-01-06 21:28:12.000000000 -0600
++++ bdfedit1.3/bdfedit.samprc 2009-01-06 21:28:35.000000000 -0600
+@@ -1,9 +1,8 @@
+ #
+-# SAMPLE .bdfeditrc
+-# edit as desired and place in $HOME/.bdfeditrc
++# set your authoring credits
+ #
+ set default(COMMENT) {
+- Copyright (c) 2000, Your Name Here
++ Copyright (c) 2008, Your Name Here
+
+ License to copy and distribute for both commercial and
+ non-commercial use is herby granted, provided this notice
+@@ -17,7 +16,7 @@
+ written by Thomas A. Fine
+ }
+ #
+-# the following values are used when a new font is created
++# set the default values to be used for new fonts
+ #
+ set default(FOUNDRY) Fine
+ set default(WIDTH) 9
diff --git a/bdfedit.desktop b/bdfedit.desktop
new file mode 100644
index 000000000000..623d067ad323
--- /dev/null
+++ b/bdfedit.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=bdfedit
+GenericName=Font Editor
+Comment=A BDF font editor
+TryExec=/usr/bin/bdfedit
+Exec=bdfedit
+Icon=/usr/share/pixmaps/bdfedit.xpm
+Categories=Graphics;
diff --git a/bdfedit.png b/bdfedit.png
new file mode 100644
index 000000000000..c7e0bfb50ead
--- /dev/null
+++ b/bdfedit.png
Binary files differ