summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorĽubomír Kučera2021-10-12 23:18:36 +0200
committerĽubomír Kučera2021-10-12 23:18:36 +0200
commitb604e0d81b7736be2f10619701712c1bdebe48a5 (patch)
tree299c6c05619d74dbd152f8258c0eef900180620e
parent6ad9798fa0890f807bab28d1db0346d83e78558b (diff)
downloadaur-b604e0d81b7736be2f10619701712c1bdebe48a5.tar.gz
Update to version 6.2.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
-rw-r--r--setup.patch13
3 files changed, 38 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e307560550b..ca844bdf8da3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = beautysh
pkgdesc = A Bash beautifier for the masses
- pkgver = 6.1.0
+ pkgver = 6.2.1
pkgrel = 1
url = https://github.com/bemeurer/beautysh
arch = any
license = MIT
+ depends = python-colorama
depends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/b/beautysh/beautysh-6.1.0.tar.gz
- sha256sums = 966b4acb877ad3606a96524e42c8368f0fdff30058340b497788ec4161b7d544
+ source = https://files.pythonhosted.org/packages/source/b/beautysh/beautysh-6.2.1.tar.gz
+ source = setup.patch
+ sha256sums = 423e0c87cccf2af21cae9a75e04e0a42bc6ce28469c001ee8730242e10a45acd
+ sha256sums = SKIP
pkgname = beautysh
-
diff --git a/PKGBUILD b/PKGBUILD
index 03f94e53d26b..ae18ae172040 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,30 @@
# Maintainer: Ľubomír 'the-k' Kučera <lubomir.kucera.jr at gmail.com>
pkgname=beautysh
-pkgver=6.1.0
+pkgver=6.2.1
pkgrel=1
pkgdesc="A Bash beautifier for the masses"
arch=('any')
url='https://github.com/bemeurer/beautysh'
license=('MIT')
-depends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('966b4acb877ad3606a96524e42c8368f0fdff30058340b497788ec4161b7d544')
+depends=(
+ python-colorama
+ python-setuptools
+)
+source=(
+ "https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ setup.patch
+)
+sha256sums=(
+ 423e0c87cccf2af21cae9a75e04e0a42bc6ce28469c001ee8730242e10a45acd
+ SKIP
+)
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch < ../setup.patch
+}
package() {
cd "${pkgname}-${pkgver}"
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..516f3047e327
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,13 @@
+--- setup.py 2021-10-12 23:14:00.636940788 +0200
++++ setup.py 2021-10-12 23:14:18.544129869 +0200
+@@ -8,9 +8,7 @@
+ {'': ['*']}
+
+ install_requires = \
+-['colorama>=0.4.4,<0.5.0',
+- 'types-colorama>=0.4.3,<0.5.0',
+- 'types-setuptools>=57.4.0,<58.0.0']
++['colorama']
+
+ entry_points = \
+ {'console_scripts': ['beautysh = beautysh:main']}