summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHal Incandenza2016-06-06 16:37:21 -0400
committerHal Incandenza2016-06-06 16:37:21 -0400
commit8a91f2b8918396d701cd2dc334c5756397a618a2 (patch)
treee9c51b462e0e1abad6166b094c0f369ce9dc9831
parent5e6e2f61f7caa931893de35fa04c86bae46dc9a4 (diff)
downloadaur-8a91f2b8918396d701cd2dc334c5756397a618a2.tar.gz
fix build for real this time
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--clangfix.patch40
3 files changed, 3 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b70a9ee0040..960dc3536e10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 31 02:36:45 UTC 2016
+# Mon Jun 6 20:37:07 UTC 2016
pkgbase = beignet
pkgdesc = A GPGPU System for Intel Ivybridge GPUs
pkgver = 1.1.2
- pkgrel = 4
+ pkgrel = 5
url = http://cgit.freedesktop.org/beignet/
arch = x86_64
license = LGPL2.1
diff --git a/PKGBUILD b/PKGBUILD
index 4b9c2aaab7e1..6a1c3f3f895c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Current Maintainer: Leopold Bloom <blinxwang@gmail.com>
pkgname=beignet
pkgver=1.1.2
-pkgrel=4
+pkgrel=5
pkgdesc='A GPGPU System for Intel Ivybridge GPUs'
arch=('x86_64')
url='http://cgit.freedesktop.org/beignet/'
diff --git a/clangfix.patch b/clangfix.patch
index 858556d288c3..0c8656fca4b7 100644
--- a/clangfix.patch
+++ b/clangfix.patch
@@ -453,37 +453,6 @@ index 422f16b..2bf3d04 100644
/* FIXME: Because the OpenCL language do not support va macro, and we do not want
to introduce the va_list, va_start and va_end into our code, we just simulate
-diff --git a/backend/src/llvm/llvm_profiling.cpp b/backend/src/llvm/llvm_profiling.cpp
-index 211aa43..96c95ee 100644
---- a/backend/src/llvm/llvm_profiling.cpp
-+++ b/backend/src/llvm/llvm_profiling.cpp
-@@ -135,7 +135,7 @@ namespace gbe
- builder = new IRBuilder<>(module->getContext());
-
- /* alloc a new buffer ptr to collect the timestamps. */
-- builder->SetInsertPoint(F.begin()->begin());
-+ builder->SetInsertPoint(&*F.begin()->begin());
- llvm::Constant *profilingBuf = module->getGlobalVariable("__gen_ocl_profiling_buf");
- if (!profilingBuf) {
- profilingBuf = new GlobalVariable(*module, intTy, false,
-@@ -174,7 +174,7 @@ namespace gbe
- continue;
-
- // Insert the first one at beginning of not PHI.
-- builder->SetInsertPoint(instI);
-+ builder->SetInsertPoint(&*instI);
- /* Add the timestamp store function call. */
- // __gen_ocl_store_timestamp(int nth, int type);
- Value *Args[2] = {ConstantInt::get(intTy, pointNum++), ConstantInt::get(intTy, profilingType)};
-@@ -190,7 +190,7 @@ namespace gbe
- BE--;
- BasicBlock::iterator retInst = BE->end();
- retInst--;
-- builder->SetInsertPoint(retInst);
-+ builder->SetInsertPoint(&*retInst);
- Value *Args2[2] = {profilingBuf, ConstantInt::get(intTy, profilingType)};
-
- builder->CreateCall(cast<llvm::Function>(module->getOrInsertFunction(
diff --git a/backend/src/llvm/llvm_scalarize.cpp b/backend/src/llvm/llvm_scalarize.cpp
index 899a696..9efb897 100644
--- a/backend/src/llvm/llvm_scalarize.cpp
@@ -497,15 +466,6 @@ index 899a696..9efb897 100644
}
DenseMap<Value*, VectorValues> vectorVals;
-@@ -740,7 +740,7 @@ namespace gbe {
- while (isa<AllocaInst>(bbIter)) ++bbIter;
-
- IRBuilder<> allocBuilder(&entry);
-- allocBuilder.SetInsertPoint(bbIter);
-+ allocBuilder.SetInsertPoint(&*bbIter);
-
- Alloc = allocBuilder.CreateAlloca(fooTy, nullptr, "");
- for (int i = 0; i < GetComponentCount(foo); ++i)
@@ -801,7 +801,7 @@ namespace gbe {
return;
ReversePostOrderTraversal<Function*> rpot(&F);