summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-03-18 21:32:25 +0100
committerNarrat2022-03-18 21:32:25 +0100
commitbf51992070c69bbee02d8f35eea6c1db1cc6ffd8 (patch)
tree5ea5c1aa9517ef1661e8d4c836054a24e5f8ddf1
parent4fdd96ef39056f9999abd3022f0e2700c07417e3 (diff)
downloadaur-bf51992070c69bbee02d8f35eea6c1db1cc6ffd8.tar.gz
bemenu-git: sync with [community]
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD80
-rw-r--r--bemenu-wayland-git.install8
3 files changed, 100 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48a51f417048..cb3237842f2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,52 @@
pkgbase = bemenu-git
- pkgdesc = Dynamic menu library and client program inspired by dmenu with support for wlroots-based wayland compositors
- pkgver = r382.d9f4d1b
+ pkgdesc = Dynamic menu library and client program inspired by dmenu
+ pkgver = 0.6.7.r1.g81b5091
pkgrel = 1
url = https://github.com/Cloudef/bemenu
arch = x86_64
license = GPL3
license = LGPL3
- makedepends = cmake
makedepends = libxinerama
makedepends = libxkbcommon
makedepends = ncurses
+ makedepends = pango
makedepends = wayland
+ makedepends = wayland-protocols
makedepends = wlroots
- depends = pango
- optdepends = libxinerama: For the x11 backend
- optdepends = libxkbcommon: For the wayland backend
- optdepends = ncurses: For the curses backend
- optdepends = wayland: For the wayland backend
- optdepends = wayland-protocols: For the wayland backend
- optdepends = wlroots: For the wayland backend
- provides = bemenu
- conflicts = bemenu
- source = bemenu::git+https://github.com/Cloudef/bemenu
+ makedepends = scdoc
+ source = git+https://github.com/Cloudef/bemenu
sha256sums = SKIP
pkgname = bemenu-git
+ depends = bemenu-renderer-git
+ provides = libbemenu-git
+ provides = bemenu
+ conflicts = bemenu
+pkgname = bemenu-ncurses-git
+ pkgdesc = ncurses renderer for bemenu
+ depends = libbemenu-git
+ depends = ncurses
+ provides = bemenu-renderer-git
+ provides = bemenu-ncurses
+ conflicts = bemenu-ncurses
+
+pkgname = bemenu-x11-git
+ pkgdesc = X11 renderer for bemenu
+ depends = libbemenu
+ depends = libxinerama
+ depends = pango
+ provides = bemenu-renderer-git
+ provides = bemenu-x11
+ conflicts = bemenu-x11
+
+pkgname = bemenu-wayland-git
+ pkgdesc = Wayland (wlroots-based compositors) renderer for bemenu
+ install = bemenu-wayland-git.install
+ depends = libbemenu
+ depends = libxkbcommon
+ depends = pango
+ depends = wayland
+ provides = bemenu-renderer-git
+ provides = bemenu-wayland
+ conflicts = bemenu-wayland
diff --git a/PKGBUILD b/PKGBUILD
index ddb1a93f12fc..7148d819910a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,72 @@
-# Maintainer: Danny Bautista <aur at pyrolagus.de>
-# https://github.com/Earnestly/pkgbuilds/tree/master/bemenu-git
-pkgname=bemenu-git
-_pkgname="bemenu"
-pkgver=r382.d9f4d1b
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Ivy Foster <iff@archlinux.org>
+# Contributor: Christian Rebischke <chris.rebischke@archlinux.org>
+# Contributor: Danny Bautista <aur at pyrolagus.de>
+
+_pkgbase=bemenu
+pkgbase=bemenu-git
+pkgname=(bemenu-git bemenu-ncurses-git bemenu-x11-git bemenu-wayland-git)
+pkgver=0.6.7.r1.g81b5091
pkgrel=1
# Wayland without wlroots is not supported.
# https://github.com/Cloudef/bemenu/issues/79#issuecomment-572867783
-pkgdesc='Dynamic menu library and client program inspired by dmenu with support for wlroots-based wayland compositors'
+pkgdesc='Dynamic menu library and client program inspired by dmenu'
url='https://github.com/Cloudef/bemenu'
arch=(x86_64)
license=(GPL3 LGPL3)
-provides=('bemenu')
-conflicts=('bemenu')
-depends=(pango)
-makedepends=(cmake libxinerama libxkbcommon ncurses wayland wlroots)
-optdepends=(
- 'libxinerama: For the x11 backend'
- 'libxkbcommon: For the wayland backend'
- 'ncurses: For the curses backend'
- 'wayland: For the wayland backend'
- 'wayland-protocols: For the wayland backend'
- 'wlroots: For the wayland backend'
-)
-source=("$_pkgname::git+https://github.com/Cloudef/bemenu")
+
+makedepends=(libxinerama libxkbcommon ncurses pango wayland wayland-protocols wlroots scdoc)
+
+source=(git+https://github.com/Cloudef/bemenu)
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_pkgbase"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
- make PREFIX="$pkgdir/usr"
+ cd "$_pkgbase"
+ make PREFIX=/usr
}
package_bemenu-git() {
- cd "$_pkgname"
- make install PREFIX="$pkgdir/usr"
+ depends=(bemenu-renderer-git)
+ provides=(libbemenu-git bemenu)
+ conflicts=('bemenu')
+
+ cd "$_pkgbase"
+ make DESTDIR="$pkgdir" PREFIX=/usr install-base install-docs
+}
+
+package_bemenu-ncurses-git() {
+ pkgdesc='ncurses renderer for bemenu'
+ provides=(bemenu-renderer-git bemenu-ncurses)
+ conflicts=(bemenu-ncurses)
+ depends=(libbemenu-git ncurses)
+
+ cd "$_pkgbase"
+ make DESTDIR="$pkgdir" PREFIX=/usr install-curses
+}
+
+package_bemenu-wayland-git() {
+ pkgdesc='Wayland (wlroots-based compositors) renderer for bemenu'
+ provides=(bemenu-renderer-git bemenu-wayland)
+ conflicts=(bemenu-wayland)
+ depends=(libbemenu libxkbcommon pango wayland)
+ install=bemenu-wayland-git.install
+
+ cd "$_pkgbase"
+ make DESTDIR="$pkgdir" PREFIX=/usr install-wayland
+}
+
+package_bemenu-x11-git() {
+ pkgdesc='X11 renderer for bemenu'
+ provides=(bemenu-renderer-git bemenu-x11)
+ conflicts=(bemenu-x11)
+ depends=(libbemenu libxinerama pango)
+
+ cd "$_pkgbase"
+ make DESTDIR="$pkgdir" PREFIX=/usr install-x11
}
diff --git a/bemenu-wayland-git.install b/bemenu-wayland-git.install
new file mode 100644
index 000000000000..76b8c767a62f
--- /dev/null
+++ b/bemenu-wayland-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Note: bemenu's wayland backend only works"
+ echo ' in compositors which implement wlr-layer-shell.'
+}
+
+post_upgrade() {
+ post_install
+}