summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Guarco2019-10-04 21:26:55 -0400
committerKyle Guarco2019-10-04 21:26:55 -0400
commit5612ad354311c49a5285d03eaf7509defb412f7b (patch)
tree9e5fdb6627157c291e53593d54755139eda66cf3
parent0c9e4ea7f0a2e4f53bda43fdcb7a4566bb7d3b32 (diff)
downloadaur-5612ad354311c49a5285d03eaf7509defb412f7b.tar.gz
"/usr/local" will now be created if it doesn't exist
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c22a586c1fc1..5f859bbcf260 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = berry
pkgdesc = A healthy, bite-sized window manager written over the XLib Library
pkgver = git+caf4f33
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/JLErvin/berry
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index f93026032c5c..876eceb80e4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname=berry
pkgname=berry-git
_pkgver=caf4f33
pkgver=git+$_pkgver
-pkgrel=1
+pkgrel=2
pkgdesc="A healthy, bite-sized window manager written over the XLib Library"
url="https://github.com/JLErvin/berry"
arch=('x86_64')
@@ -21,14 +21,22 @@ sha256sums=('SKIP' 'SKIP')
build() {
cd ${_pkgname}/
+ # Change to the _pkgver (Last updated commit)
git checkout $_pkgver
+ # Compile the window manager
make
}
package() {
cd ${_pkgname}/
- make DESTDIR="${pkgdir}/" PREFIX="/usr/local" install
+
+ # The installation location (from /)
+ PFIX="/usr/local"
+ # Make the directory if it doesn't exist, then install
+ mkdir -p "${pkgdir}/${PFIX}"
+ make DESTDIR="${pkgdir}/" PREFIX=$PFIX install
+ # Install the examples (sample configuration files)
mkdir -p "${pkgdir}/etc/xdg/berry"
install -D -m644 examples/* "${pkgdir}/etc/xdg/berry/"
}