summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Guarco2019-06-26 14:30:20 -0400
committerKyle Guarco2019-06-26 14:30:20 -0400
commit5e46779fcfc95eeeb1fee68e7753d66a998176fa (patch)
treee0c22de575167bd1f628ade6befb950757065a2c
parent1b209ba23e28c01d27fced974a180a2a1ec75d67 (diff)
downloadaur-5e46779fcfc95eeeb1fee68e7753d66a998176fa.tar.gz
Fixed upstream build issue, temp fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--makefile.patch15
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf4e4a9c8243..5ce46c456123 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = berry
pkgdesc = A healthy, bite-sized window manager written over the XLib Library
- pkgver = git+8d72619
+ pkgver = git+30b94e5
pkgrel = 1
url = https://github.com/JLErvin/berry
arch = x86_64
@@ -9,7 +9,9 @@ pkgbase = berry
depends = libx11
source = git://github.com/JLErvin/berry.git#branch=master
source = berry.desktop
- sha256sums = SKIP,
+ source = makefile.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = berry-git
diff --git a/PKGBUILD b/PKGBUILD
index f5c7c5e55d0c..9bb992f14e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=berry
pkgname=berry-git
pkgbase=berry
-pkgver=git+8d72619
+pkgver=git+30b94e5
pkgrel=1
pkgdesc="A healthy, bite-sized window manager written over the XLib Library"
url="https://github.com/JLErvin/berry"
@@ -14,12 +14,18 @@ depends=('libx11')
source=(
"git://github.com/JLErvin/berry.git#branch=master"
berry.desktop
+ "makefile.patch"
)
-sha256sums=('SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP')
# For later.
#install -D -m644 ../berry.desktop "${pkgdir}/usr/share/xsessions/"
+prepare() {
+ cd $srcdir/${_pkgname}/
+ patch --strip=1 < ../makefile.patch
+}
+
build() {
cd ${_pkgname}/
make
@@ -27,7 +33,7 @@ build() {
package() {
cd ${_pkgname}/
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" PREFIX="/usr/local" install
cd man/
make DESTDIR="$pkgdir/" install
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..e533aeea3b1e
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile b/Makefile
+index 6e25cbf..7d4207e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -14,8 +14,8 @@ all:
+
+ install:
+ mkdir -p "$(DESTDIR)$(PREFIX)/bin"
+- install $(__NAME__) "/usr/local/bin/$(__NAME__)"
+- install $(__NAME_C__) "/usr/local/bin/$(__NAME_C__)"
++ install $(__NAME__) "$(DESTDIR)/usr/local/bin/$(__NAME__)"
++ install $(__NAME_C__) "$(DESTDIR)/usr/local/bin/$(__NAME_C__)"
+ cd ./man; $(MAKE) install
+
+ clean: