summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2021-02-07 18:28:29 -0500
committerSandy Carter2021-02-07 18:28:29 -0500
commit2ace513d25bdfd26fa1d260c0f74f3f411ca6879 (patch)
tree5da1620046bdd596760c962ce14f9792ef5e249c
parentc087d363cf04916ff3c89fe5967af6d86ac93c6c (diff)
downloadaur-2ace513d25bdfd26fa1d260c0f74f3f411ca6879.tar.gz
Fix patch files' line ending issues
-rw-r--r--.SRCINFO4
-rw-r--r--.gitattributes1
-rw-r--r--0001-cmake-turn-on-CMAKE_POSITION_INDEPENDENT_CODE-for-sh.patch56
-rw-r--r--PKGBUILD17
4 files changed, 41 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 011e68d23f26..f26fce59722b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bgfx-cmake-git
pkgdesc = Cross-platform, graphics API agnostic, "Bring Your Own Engine/Framework" style rendering library. (With CMake build scripts)
- pkgver = r7631.741028840
+ pkgver = r7652.7daf5e0ba
pkgrel = 1
url = https://bkaradzic.github.io/bgfx
arch = x86_64
@@ -25,7 +25,7 @@ pkgbase = bgfx-cmake-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 164c5d569d605f3e02552ad57383fbb2448e48270cdb95009672ade6e1be8050
+ sha256sums = eaf8ef931488b41614125459bee028659d082637922c0475400cb68438b78eed
sha256sums = 20d6949f9a5d95bd0f21c51a99baca8b84163462b42a5472c2b237ee915993cc
sha256sums = 471c2f61b071246bd653623e5939aa2874aac7b006af6907459b1a3c23dc1952
sha256sums = 294df452d039824ac8280af6089918ac09a5feafd3bc1821e125e602cca073fa
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..ec1ffa81eddd
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+*.patch -text
diff --git a/0001-cmake-turn-on-CMAKE_POSITION_INDEPENDENT_CODE-for-sh.patch b/0001-cmake-turn-on-CMAKE_POSITION_INDEPENDENT_CODE-for-sh.patch
index 34aab28d60d1..d1095f7ac550 100644
--- a/0001-cmake-turn-on-CMAKE_POSITION_INDEPENDENT_CODE-for-sh.patch
+++ b/0001-cmake-turn-on-CMAKE_POSITION_INDEPENDENT_CODE-for-sh.patch
@@ -1,28 +1,28 @@
-From db7e9cb07341043ac9949012d9e1a978fa7c8508 Mon Sep 17 00:00:00 2001
-From: Sandy Carter <bwrsandman@gmail.com>
-Date: Sat, 30 Jan 2021 19:33:13 -0500
-Subject: [PATCH 1/4] cmake: turn on CMAKE_POSITION_INDEPENDENT_CODE for shared
-
-This prevents an error while linking libbx.a into libbgfx.so on linux
----
- CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 52a7315..4412be1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -41,6 +41,10 @@ set( BGFX_LIBRARY_TYPE "STATIC" CACHE STRING "Linking type for library" )
-
- set_property( CACHE BGFX_LIBRARY_TYPE PROPERTY STRINGS STATIC SHARED )
-
-+if( BGFX_LIBRARY_TYPE MATCHES "SHARED" )
-+ set(CMAKE_POSITION_INDEPENDENT_CODE ON)
-+endif()
-+
- if( NOT BX_DIR )
- set( BX_DIR "${CMAKE_CURRENT_SOURCE_DIR}/bx" CACHE STRING "Location of bx." )
- elseif( NOT IS_ABSOLUTE "${BX_DIR}")
---
-2.30.0
-
+From db7e9cb07341043ac9949012d9e1a978fa7c8508 Mon Sep 17 00:00:00 2001
+From: Sandy Carter <bwrsandman@gmail.com>
+Date: Sat, 30 Jan 2021 19:33:13 -0500
+Subject: [PATCH 1/4] cmake: turn on CMAKE_POSITION_INDEPENDENT_CODE for shared
+
+This prevents an error while linking libbx.a into libbgfx.so on linux
+---
+ CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 52a7315..4412be1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -41,6 +41,10 @@ set( BGFX_LIBRARY_TYPE "STATIC" CACHE STRING "Linking type for library" )
+
+ set_property( CACHE BGFX_LIBRARY_TYPE PROPERTY STRINGS STATIC SHARED )
+
++if( BGFX_LIBRARY_TYPE MATCHES "SHARED" )
++ set(CMAKE_POSITION_INDEPENDENT_CODE ON)
++endif()
++
+ if( NOT BX_DIR )
+ set( BX_DIR "${CMAKE_CURRENT_SOURCE_DIR}/bx" CACHE STRING "Location of bx." )
+ elseif( NOT IS_ABSOLUTE "${BX_DIR}")
+--
+2.30.0
+
diff --git a/PKGBUILD b/PKGBUILD
index b0a3f561096e..e09756e81643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=bgfx-cmake-git
-pkgver=r7631.741028840
+pkgver=r7652.7daf5e0ba
pkgrel=1
pkgdesc="Cross-platform, graphics API agnostic, \"Bring Your Own Engine/Framework\" style rendering library. (With CMake build scripts)"
arch=('x86_64')
@@ -19,8 +19,11 @@ source=('git://github.com/bkaradzic/bx.git'
'0002-bimg-specify-visibility-of-linked-libs.patch'
'0003-install-if-generating-shared-only-install-bgfx.patch'
'0004-bgfx-make-bx-and-bimg-private.patch') # https://github.com/widberg/bgfx.cmake/pull/100
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP'
- '164c5d569d605f3e02552ad57383fbb2448e48270cdb95009672ade6e1be8050'
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'eaf8ef931488b41614125459bee028659d082637922c0475400cb68438b78eed'
'20d6949f9a5d95bd0f21c51a99baca8b84163462b42a5472c2b237ee915993cc'
'471c2f61b071246bd653623e5939aa2874aac7b006af6907459b1a3c23dc1952'
'294df452d039824ac8280af6089918ac09a5feafd3bc1821e125e602cca073fa')
@@ -39,10 +42,10 @@ prepare() {
git submodule sync
git submodule update --init
- patch -p1 -i $srcdir/0001-cmake-turn-on-CMAKE_POSITION_INDEPENDENT_CODE-for-sh.patch
- patch -p1 -i $srcdir/0002-bimg-specify-visibility-of-linked-libs.patch
- patch -p1 -i $srcdir/0003-install-if-generating-shared-only-install-bgfx.patch
- patch -p1 -i $srcdir/0004-bgfx-make-bx-and-bimg-private.patch
+ patch --binary -p1 -i $srcdir/0001-cmake-turn-on-CMAKE_POSITION_INDEPENDENT_CODE-for-sh.patch
+ patch --binary -p1 -i $srcdir/0002-bimg-specify-visibility-of-linked-libs.patch
+ patch --binary -p1 -i $srcdir/0003-install-if-generating-shared-only-install-bgfx.patch
+ patch --binary -p1 -i $srcdir/0004-bgfx-make-bx-and-bimg-private.patch
# prepend bgfx to bin names to avoid naming conflicts
for BIN in geometryc geometryv shaderc texturec texturev