summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wilzbach2015-10-11 15:25:49 +0300
committerSebastian Wilzbach2015-10-11 15:25:49 +0300
commit58cb671106dab7d05a1d19ef535a6e76cdb288b4 (patch)
tree859a29fb4ca3e63cdcac2f3132c5eb69cde80293
downloadaur-bib2x.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD29
-rw-r--r--generic.h.patch11
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f76e736f941b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bib2x
+ pkgdesc = The Tool For Manipulating and Converting BibTeX-Libraries
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = http://www.xandi.eu/bib2x/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://www.xandi.eu/bib2x/files/dist/bib2x_0.9_src.tgz
+ md5sums = 58dc19125305762eba9725260e191622
+
+pkgname = bib2x
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8297f11b98bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sebastian Wilzbach <sebi [at] wilzbach [dot] me>
+# Maintainer: trex279 <gmail.com: trex279>
+
+pkgname=bib2x
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="The Tool For Manipulating and Converting BibTeX-Libraries"
+arch=('i686' 'x86_64')
+url="http://www.xandi.eu/bib2x/"
+license=('GPL')
+source=("http://www.xandi.eu/bib2x/files/dist/bib2x_0.9_src.tgz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i "${startdir}/generic.h.patch"
+
+ ./configure --prefix=/usr
+
+ make ECHO=echo
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make prefix="$pkgdir/usr/" install
+}
+
+md5sums=('58dc19125305762eba9725260e191622')
diff --git a/generic.h.patch b/generic.h.patch
new file mode 100644
index 000000000000..22bd44bef0a4
--- /dev/null
+++ b/generic.h.patch
@@ -0,0 +1,11 @@
+--- bib2x-0.9.0/include/generic.h 2006-06-05 11:52:54.000000000 -0500
++++ bib2x-0.9.0/include/generic.h 2012-08-23 18:20:41.874210161 -0500
+@@ -41,6 +41,8 @@
+ #include <map>
+ #include <iostream>
+ #include <fstream>
++#include <string.h>
++#include <stdlib.h>
+
+ namespace odb
+ {